Cart 3 Yuzool working? Solved

Does anybody have the Cart 3 of yuzool live on his/here site? With working stripe account? Does anybody know if you have to replace all the products/items in cart 2 to be SCA compliant and do they mix and match? Its working in the RW preview or when I have it local but it does not work when published…

I’ve just put together first @yuzoolthemes Cart3 project to sell training courses using Stripe only (not PayPal). Opens all the right products and prices in the Cart but will not direct to a Stripe checkout page. I have not mixed and matched - everything should be using Cart3 stacks. Not sure what I’m missing here.

Think your link is incorrect? Should be

I found your Stripe payment opens the traditional stripe pop up on the English page but on the Dutch page - like mine - it doesn’t do anything. As far as I am aware, Cart3 doesn’t open a Stripe pop up beyond the cart - it should take you straight to a Stripe checkout page

Thx for your reply - indeed the the url was wrong…
the French and English version are not changed and are cart 2 working as ever. In Rapidweaver preview the cart 3 stack is working…and i am redirrected to Stripe imediately but when I publish it online it stops working.

I have set up a test on my own website: and it works fine. (This is using live keys so don’t make a payment unless you’re feeling generous)

So this is a mystery to me. I can’t get the test to work on my client site - it won’t even try to connect to the Stripe checkout page.

Still at least I know it fundamentally works so detective time. Probably a silly error on my part.

I have send the following message to Yuzool

Hello Michael Having troubles with Cart 3 on
I put again a mini website to show you - the problem is when I check out with stripe there is no next screen with the price etc
The original site is on - only Nederlands is with cart 3 the other french and English are still under cart 2 these work fine…

I get this error

Warning: require_once(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /home/learnspo/public_html/… on line 20

Parse error: syntax error, unexpected ‘->’ (T_OBJECT_OPERATOR) in /home/learnspo/public_html/… on line 20

In the rapidweaver preview everything is working but once I publish it stops working -

Now I uploaded the Cart3demo to and i’m getting the same errors…

I’ve seen error messages similar to that before, it was down to the server setting the time and date incorrectly. Try checking your server is setting them correctly.

I did find some code that you could add to the page to fix incorrect time settings, I can grab it and share it olwhen I’m back in the office, maybe later today or maybe Monday.

ok thx

Ok I found it - I updated the PHP version and set the time to CEST and the Cart 3 Module is working as sunshine. Thanks for the hint you have pointed me in the direction of a solution…

1 Like

well no joy here. Anyone take a look and guess what I might be doing wrong? This is a test page that’s off the menu and, unlike the real page, doesn’t have any lightboxes or anything else going on:

When I set up a test payment within a Machform, everything worked fine (this is now removed). Using Cart3, the cart calculates as it should but will not link to the Strip checkout page. No error message, it just does nothing. Have double checked the test keys and they’re fine. I’m at a loss, particularly as I have Cart 3 working on our own website.

Just a question are the two sites on the same server?
When I asked the support they pointed me to two errors…
Here is what I see in the error log:

[12-Sep-2019 14:21:40 Europe/Berlin] PHP Parse error: syntax error, unexpected ‘->’ (T_OBJECT_OPERATOR) in /home/myanvtpw/ line 20

Then I contacted the support of my hoster again to update the php - in cpanel you can upgrade the php version and there the timezone was wrong…
After correcting this with 3 different websites - with two different hosters everything is working…

Also important all the files that have a cart including thank you and cancel page must have the name index.php - no html no seo name like contact.php…

I will have a look at your site if I have any solutions I will give them here…

Sorted! I knew it would be something stupid. I put the product amount in with no decimal i.e. 49 and not 49.00

All resolved now!

Great that you have it fixed, but neither Cart 2 & 3 requires decimals. At least not so far as I can see.

I bought Cart3 over the weekend and am now upgrading some sites by copying over the settings from 2 to 3. I don’t have any decimals and so far it’s working fine. The demo sent with Cart3 doesn’t seem to use decimals either.

As I say, great it’s fixed, but maybe worth checking deeper in case whatever the problem was, returns.

1 Like

I have though just discovered that Cart3 doesn’t appear to redirect to Stripe when using test keys.

Anyone else?

@yuzoolthemes ?

Hello !

I’m new here, didn’t know this place…

I have a very similar problem too here :
When you want to checkout with Stripe (after selecting a product) : you never get to the “Stripe checkout page”.
Always to this address : that does not exist…

I have checked carefully all my prices (I already had a problem with them, putting a comma instead of a point ;-)

So I’m stuck too…

Some screenshots of your settings within the Cart3 Base stack might help. It’s impossible to help with just the redirect URL.

I didn’t think so either, but where I had 49 and replaced with 49.00 it solved the problem - using test keys.

Sure I can do that, but I don’t think my problem comes from my settings ; I already spent hours to try to fix it… (And… if it is a setting problem, I’ll feel stupid ;-)

Interesting. Test keys don’t work for me, with or without decimals!

EDIT: My bad, I was using the test keys from my euro account with a GBP payment page!

So, @Manofdogs I’ve just tried this page: which is presently in test mode with test keys (to the correct currency!) and prices without decimals are working.

1 Like

Yes, it is two times now that I try to check every price, didn’t fin any mistake…

That said ; I could create a much simpler page to test that “amount problem”… I’m going to do so !