Cosmetic issues when opening a Limelight Lightbox inside a Sections Pro stack

Hi Andrew,

no, “Scroll into view on open” was not selected. I now turned it on, but the result is not very nice:
The Limelights are always moving up when being selected. Hm, I don’t need any movement or animation or whatsoever. Simply a change of content without anything else. What am I still doing wrong…?

Thanks and best wishes,

(in addition to this post on WS)
“Cosmetic issues when opening a Limelight Lightbox inside a Sections Pro stack…: When I click on the four options on the left on this page … … the page always moves up. Hm, difficult to describe…: So, when you scroll down the page so that you see the whole wine bottle and then click on any of the four links (strange: except for the top link “pep”!”) the content seems to “jump”, although all areas do have exactly the same amount of content. I would like that the page content just stays where it is and only switching the content of the Sections Pro stack."

Its an odd one. Can you turn scroll into view off again please - I just wanted to make sure that it was not selected.

It seems like the problem is in some way related to the fact that the target section is at the bottom of the content.

A little test: add a 1 col below with 1000px padding (or anything to make some space) - does this change the behaviour?

Does changing the theme make a difference? It looks like there is some smooth scroll in operation somewhere.

You can send me a cut down project with that page if you want.

I’ve now added a column with some padding below the Limelight/Sections Pro, and now LL behaves quite good. Except when you scroll to the very bottom of the page and then click on one of the LL links. Then the page jumps to a certain point again:
But I can live with that… You can have a look at the project file nevertheless here (maybe there’s to optimize…):

Thanks. I’ll look at the file later. Now I know what is causing it, I’ll try and work out why.

1 Like

Hi Tav, did you already find the time to have a look at this?

Sorry, chaotic times and I forgot.

It will always reposition once to show the content - I think this is OK behaviour.

The jumps afterwards are wrong.

I think they are caused by the button links. If you change the buttons to be of type button instead of link and add the LL launch ID to the button custom class setting instead of the link dialog then it seems to stop the jumps.

Here is your project with those changes and with the padded 1 col removed. Is this now acceptable?

Thanks Tav, but I don’t see any change in behavior. Maybe you have sent me the wrong project file, since you are mentioning that you did remove the padded 1 col, but this column is still there in the file (while the buttons actually now have the type of “button”). When I delete that column the LL content is placed too low again. Would be glad if you could have another look at this, thanks. :)

Weird, it was not jumping at all when I tested it but you are right, I’ve sent the wrong file. Trouble is now I can’t fix it again. I think I will have to delve a bit deeper and find out what is happening.
Can you open a ticket on BWD support - it will just make it easier to track. If you just send an email with the subject of Limelight Jumping or similar then we can take it from there - threads on here disappear to easily when I’ve read them.

Is lazy load enabled for the Limelight content? I remember having a jumping issue a while back when this was enabled. Might be worth toggling that to see if it makes a difference.


@habitualshaker is spot on, thanks. Here is the correct modified file with no bottom padding and no jump

1 Like

Thanks Stuart and Andrew, this now works perfectly fine! :-)

Best wishes from Germany,