Crashing on "undo"... Grrr!

Is it just me or has this issue gotten far FAR worse under the latest version of RW?

Used to be if you waited a few moments between clicking undo, 8/10 you got away with it. Not now, not for me, one click and the whole shooting match crashes. It’s an impossible situation.

Anyone else?

Everything up to date for me, RW8.x, Stacks just updated today, etc.

What are you undoing (what a word…)?

An operation on a Stacks page?

Undoing the removal of a stack. It’s now 100% consistent for me.

Say I have two stacks on the page. I delete one. Preview. Then delete the other.

I then click edit in the main menu and the option says “undo remove”. So I click it and the last removed stack comes back. I then click edit again and instead of again saying “undo remove” it now says “undo typing” or similar. But I’ve not changed any typing (or whatever) to undo. If I click it, RW crashes.

I get the same no matter what I’m trying to undo.

At the moment I’ve no undo feature, which is not good :-(

Then @Isaiah should have a look if it is Stacks plugin related ?

Typical. Just tried to record it doing this, and of course, now it’s not doing it. It’s been doing it all bloody morning.

And therein lies the core issue: It’s NOT consistent, but for sure the crash on undo issue is getting worse (for me) not better.

That’s because you are talking to me. I have magic influence. Always when I look on other people problems, they are gone. Always.



Just happened again. This time I’d moved a stack, previewed, tried to move it back using undo… Beachball to death.

i totally believe you. i’m pretty sure i know where this bug is – but i need a couple more details to know for sure.

you say that the Edit menu says “Undo Typing” – what this means is that at some point there was some typing happening – some text-edit view popped up. it’s tough to get the “Undo Typing” to happen if you didn’t pop up the edit view.

i think that’s where the bug is – when you’re done with text-editing in stacks it ** should ** gang up all your text-edits into one-nice “Undo Typing” – but I think in some circumstances when it “gangs up” the text-editing – it’s either gathering too many actions or not enough of them.

knowing what you did right before and right after the text editing is probably the important bit.

or better yet, do this: when detailing steps like you did above (thank you thank you thank you – that’s awesome info) it’s best if the first step is:

  1. I open an new stacks page

because that’s probably what I’m going to try first.
if I start with that step and then do your procedure above – it’s seems to work ok – and it never says “Undo Typing” – unless I deviate from your procedure and add some text editing.

That doesn’t mean I’m going to throw away this info. I’ll still use it. And I’ll go hunting for bugs in that area – I think there maybe be more than one (sorry! my bad. i want it to get better too. i didn’t mean to get sick for 3 months – but i’m back on the job now – things will improve, i promise)

But if you can provide more detailed info about how you got stacks into that state that makes it behave that way – then i can definitely find and fix that specific bug – and even let you know that it’s fixed afterwards.

Thanks again for the bug hunting, super great info. 😃


1 Like

If “it” is Stacks, then it didn’t actually get worse. I was in the hospital with pneumonia. And way from my computer for 3 months. Nothing got anywhere. “it” just stood still.

But I feel you. Standing still in the tech world feels like moving backward. LOL

But I’m feeling a lot better. One more round of antibiotics and prednisone next week – hopefully that’s the last one. 🤞

After a 3 month drought – and now this – four betas and one release in the last two weeks! Woo!
I’m definitely back on the job now. Things will start to improve a bit, I promise.

1 Like

I installed RW8 and F6 at the same time about a month ago. Never had a problem with undo before that, maybe once in blue moon. Since then my undo (I use command+z) it crashes pretty much all the time, never on first stroke but usually on 2nd or up to 5.

If you tell me what you want, I’m more than happy to do what i can. If it helps, I’m happy to record the screen when working, so you can see exactly what’s going on. Just tell me what to do.

When fixing a bug I have to make the bug happen again and again:

  • to understand it
  • then to fix it
  • finally to make sure the bug is gone

If you can help me make the bug happen – or even get me close – I can fix it.

So here is what I need in a single sentence:

Find the simplest way to reliably reproduce the bug.

That’s it. That’s the whole deal.
But you have to do ALL THREE of those things:

  1. simple – THIS IS THE MOST IMPORTANT and totally mandatory
    if you can do it 1 less keystroke or click – you should
    if you can do it without installing an add-on – you should
    if you can do it starting from a blank file – you should
    the minimum setup and minimum procedure.

  2. reliable – this is pretty important
    make it happen every single time.
    if it’s an intermittent bug – make it happen often.
    if it only happened once and you can’t make it happen again – document the hell out of what happened

  3. the bug – nice to have but i’ll take it even if the bug is hard to spot
    make it so it’s really obvious what the software is doing wrong
    make it the first thing on the first page in bright red text if you can

i **** need **** you to do #1.

without simplifying the bug, i’m likely never to be able to reproduce it myself. if i can’t reproduce it, it won’t get fixed.

Sadly impossible. It’s at best an intermittent problem, so impossible for me to give you instructions to reliable duplicate it. As with the other day, I can nail it down, right down, when it decides to happen: The other day I was able to 100% replicate it, for a given period of time. Then, as Verbal Kint said, when describing his alter-ego… Poof… It’s gone!

Not trying to be obtuse, just realistic.

Yep. I get it. That’s how most bugs are. And yet… that’s my job. 🙃

But it’s not totally impossible. You already gave me some steps. They just lacked some detail. But it was a good start – which is why I encouraged you to go further…

The next two steps:

  1. Send me a crash report. More info is always good.
  2. The next time it becomes somewhat repeatable – send me the last ten actions (mouse-clicks or keystrokes) before the crash. Write them down. Record them. Make a movie. Whatever…

It’s that detail that I’m missing. Everyone assumes that other people use things the same way.

But that is very very untrue.

No bother. All today it’s been fine, but I’m back working on the same project as yesterday in a few days (interesting to see if it’s project related), if/when it starts I’ll record everything for you and send it all over.

I was going to say that it never happens to me but I can’t actually remember ever using ‘undo’. If it’s causing so much pain, can’t you do without it?