EasyCMS has stopped working on an existing EasyCMS site

I have an installation of EasyCMS on a site that I need to make some updates to that are nothing to do with the CMS. Today I noticed that the CMS is not working in RW Preview and I can’t see the current CMS data on the site. The live site that has not been updated for months is fine. Nothing has changed since the last update of this site except I recall an update to EasyCMS a few months ago. I am very reluctant to proceed with this site update until I know what’s up here.

On the sites CMS page when Previewed, I get a red warning that states `Could not communicate with TotalCMS. Either you have not published your project yet, or your website address is not properly set"

The site has certainly been published before and no change has been made to the website address.

If I add a Debug stack to the CMS page I get the following:
PHP version: 5.6.40
HTTP_HOST: www.xxxx.com
SERVER_NAME: www.xxxx.com
DOCUMENT_ROOT: /home/xxxx/public_html
DOCUMENT_ROOT (realpath): /home/xxxx/public_html
SITE ROOT: /home/xxxx/public_html
CMS VERSION: Easy CMS v1.3.1 (5225)
The RW site address is set to https://www.xxxx.com (unchanged)

The Easy/TotalCMS docs states that PHP 5.6 min is required - so that seems OK.

I do see that presumably the server of EasyCMS is 1.3.1 yet Stacks shows v1.4.2.

Anyone know if these issues are caused by the newer version of EasyCMS not working in Preview with the 1.3.1 version on the server? If not what else could it be?

PS WeaversSpace forum is currently down so unable to ask this question over there.

I have several sites running EasyCMS that seem to be working fine. None of them are running php 5.6 though. I would start by setting your php version to 7.2 minimum. It’s quite possible that since the update a current version of php may be required. Even if it isn’t you shouldn’t run a no longer supported version.

EasyCMS works great with 5.6 in my experience and the JW docs state 5.6 as a min. If the latest version of EasyCMS (v1.42) requires a newer PHP I will certainly update it but I would need confirmation that that is the issue in this case.

I generally never update anything until there is a reason to do so.

I would think since it hit end of life (no security or any type of updates) over a year ago that would be a pretty damn good reason. But to each their own.

However, I don’t know if that is why mine run and yours does not.

I can easily imagine how having one version of E-CMS on the server and another in RW could cause havoc in RW preview as well.

1 Like

I agree and hope that someone can confirm this.

This site has never been re-published and uses a very early version of easy cms (v1.1.2).

It is still working absolutely as normal in preview mode. Bear in mind though that I am testing with RW8 and I know you are still using 7.x. I would think that would be the first thing to try - open it in RW8 and see what happens (demo version if necessary). RW8 did make some changes in this respect.

In terms of your PHP -> Update it. As Scott says security concerns should mean that you always run the latest or close to the latest version but it will be more performant as well.

1 Like


I tried the project in RW8 and the result was the same in Preview - same warning message and the CMS data did not appear in Preview.

Upgrading to PHP 7.2 made no difference to this issue.

My solution/workaround was to find a Time Machine version of EasyCMS 1.3.1 and install (in RW7) , which worked correctly. I am perfectly happy to proceed with 1.3.1 and as long as I can remember not to upgrade to a newer version of EasyCMS, this work -round will keep the client content and not require me to waste more time on this.

The EasyCMS release notes point you to refer to the TCMS release notes, where I see that there are a great many updates to TCMS, but trying to determine what applies to EasyCMS is very difficult to work out. What I did see was a note that EasyCMS 1.3 was a major update and a complete export was required moving forward with 1.3. I suspect that this is the case with 1.4.2 too, but that message is not present in the release notes.

1 Like

Why don’t you log into your file manager on your hosting and just zip the entire site (which will be almost instant) then republish all files?

I would bet that the versions being different between the site and RW is the issue. A republish all would fix it.

If it doesn’t work, unzip your server file and you are back to where you started.

This is an existing site for a client that has been working fine. Any time I spend on it is time lost and it would be challenging to convince them to pay me to cover that time all due to a stack update. It works great with v1.3.1 so I have no reason to change it. This is real life overriding what is technically the better solution.

Doing a full republish with the latest v1.4.2 may be the best solution but I cannot take that risk unfortunately.

Try a local export and host it locally with MAMP. You will see if it works then before publishing.

Good suggestion and probably the best way to confirm it will work before committing to a clients site re-publish.

However, it will take time that I shouldn’t have to divert from other stuff just to prove that it will work.

It is also concerning that the error message makes little sense and is from a different product. EasyCMS was a great product but it appears to have fallen down the priority tree in terms of updates and attention to detail. This then makes you wonder if it has had enough testing.

So I will remain at the working 1.3.1 version.

IMHO CMS systems are critical web site systems and need more testing than others because when a gremlin creeps into an update it can really mess up a clients web sites and all the blame comes back to the creator of the site.