and Foundation 5

In Germany we are currently receiving a wave of warnings from lawyers because of embedded google fonts. I hadn’t thought about that before. But as it turns out most pages of my projects have these fonts in the CSS.
For example in Foundation 5. or themes like Stalker.

But I can’t find any setting that prevents or disables these fonts. Can anyone help me here or has a solution to the problem?

You are loading these Google located fonts from your Foundation project.

So you could remove them and use standard web system fonts, which will stop the calls to Google.

However, we are well into 2022, and the best way to use Google Fonts is to load them locally on you own server. A good way to do this is using the RW Resources to store the woff2 version of your Google fonts. However, Foundation does not have this facility.

All that is required is a few lines of code to load the fonts, so if you Google about you will find this method and invest a little bit of time to figure it out.

The low cost option would be to use Source to replace Foundation, which has excellent local font capability built in. It also has everything else.

Alternativey you can pay more for a stack like FontPlus.

It’s very easy to download Google fonts and upload them to your server — they make it so. So it seems unlikely that font-serving is a key part of some sinister Google data-acquisition plot. But an alternative, if you don’t want to do this, you could include consent to the use of the Google fonts in your cookie policy.

You could also use either a single HeaderPro or a ParagraphPro to load the fonts and create the font families for re-use throughout your project no matter which text stacks you are using. This way you wouldn’t have to re-build your whole project and you wouldn’t need to buy a separate font solution.

1 Like

Saving the fonts locally is not difficult. I just don’t know how to remove the in the CSS. Above all, where can I find the CSS, where and how can I edit the CSS and, above all, which code must be set for it. Unfortunately I’m not a programmer and I used Rapidweaver because I can’t program. Kann mir hierzu jemand weiterhelfen?

I presume that you just specified the fonts in the Foundation Site Styles stack. This will be automatically calling the Google Fonts API.

Simply change the setting to FontPro for all 3 fonts - this will just stop Site Styles from loading any font. It does not matter that you are not using Font Pro, it just turns off font loading.

You can then use the settings in the Header Pro stack or the Paragraph Pro stack to load your local fonts for the whole page (if you want a totally free solution) or you can buy the Font Pro stack from Joe or any of the other font loading stacks out there if you want a paid solution.

None of the above involves any coding whatsoever.


For reference: