Foundation Forms slider : displays "NaN" instead of numbers

Hello !

In this page ; when you use a browser (tried Safari, Firefox and Chrome) and play around with the sliders : you get the chosen value displaying at the right of the slider.

But ; when I do the same on an iPhone or an iPad with iOS 13.3 ; I get “NaN” (means Not a Number ?) as a result, displaying there.

I tried with an iPhone iOS 11.2 ; then the values are displaying ok…

So I understand this could be an iOS problem, but do you understand why ? What could I do to solve this ?

Tahnks ;-)

The NaN issue also occurs on iOS 14.4.2.

To answer your questions, I suspect the main answer is that Foundation (6 years old?) hasn’t been updated for the forms to work correctly with todays iOS. JW will be the best person to answer this. To solve the issue you could use a better form such as FormsSnap or even better, use MachForms.

1 Like

I can’t try your page on an iPhone plugged into a Mac at the moment to debug it but this page works fine still on iOS and uses F1

1 Like

Thanks guys.

Webdeersign ; this page is just something I made for a friend to test something he wants to create, so I’m not going to buy anything now. But I took a look at FormsSnap and MachForms thanks.
It made me realize that I also have an (old) copy of FormLoom 3 from Yabbad and it seems not to work anymore ; I checked the functions once again, maybe I could buy FormLoom 4 some day. I’ll try to understand the little differences between FormLoom and FormSnap (I understood that one is a plugin and the other is a stack. If they do the same job I would prefer a stack).

tav ; what is F1 ?

I think it’s Foundation 1

1 Like

Yes F1 is Foundation 1

Have you got the latest version of Formloom 3? There was an issue with it a while ago and it stopped working but an update fixed it. It also had a companion stack to allow it to be used/imported to a stacks page.

There are a lot of form options out there, what do you actually need it to do?

Yes Foundation stacks v1 (Foundation 5)

F1, of course… ;-)

I have checked more closely what both FormLoom and FormSnap offer : I think I’ll just buy one of those if the project keeps going on. Unless I can use FormLoom3, with is not the case right now.

pmjd : So I have FormLoom3 Remote, version 1.0, not updated surely. And it seems not to work properly, I can’t get to any settings. I found a 2.4 version on RW’s forum, but did not appear in RapidWeaver after installation… I didn’t find any update on Yabdab website, if you have a link…

I tested with safari on ipad with v14.4.2
If I touch the handle if the slider first and pull it aside, it works and shows numbers.
However, when I touch the slider (so not the handle) it shows NaN.

Unarchived it, Formloom Remote was version 1.0, look at the bottom of the page to find the setting to link to the Formloom plugin page. Haven’t tried publishing it yet to test if it works.

What do yo need the form to do, as you mentioned a slider and I can’t see that in Formloom 3. It is present in Formsnap 4, and other form stacks like FormsPlus.

Yes ; if the project goes on I’ll just buy FormSnap4 or something approaching
, what I have is quite old and it’s fair to pay an newer tool from time to time.
And I have checked Chilidog’s FormsPlus too.
Thank you all :-)