iFrame in Limelight


#1

Hey @tav, any clue why the links in this iFrame don’t seem to be working?
https://rotarytickets.ca/events/

Try clicking on the first event (the Casino night). I can’t get it to open. If I shift-click (as if to open it in a new window), it works. If I visit the original iFrame (https://airdrierotary.simpletix.com/) the links seem to work.


#2

Ah, it may be a ‘mixed content’ issue with the origin iFrame. Would that be a logical cause?


#3

A lot of sites prevent their pages from being iFramed with either a bit of code in their header or something similar in their htaccess.
You could be running up against that.


#4

They have some documentation on their site around embedding onto websites so I don’t think it’s intentionally doing that. I was able to get it to work in Firefox on my windows comp but not in Chrome (and not in Firefox on my macbook).

I’ve sent an email to the other folks asking if there’s a way to force https on their page. If that doesn’t fix it, at least it’ll get rid of that browser error. In a short while I’ll going to do a quick test with a different stack (Embed) to see if I can rule out any issue with Limelight…


#5

Ive just tested it in Chrome, FF and Edge in Windows. Chrome and FF dont do anything and Edge wipes the page clean … non of them open.
I think it is the mixed content, this is the error msg in FF:
Blocked loading mixed active content "http://airdrierotary.simpletix.com//event-detail.aspx?ShowId=40689"

Have you tried popping an ‘s’ on the http just to see what it does?


#6

It is a simple SSL problem.

Open the console and watch the error appear when you click the link


#7

I can’t see where I would add it. I have it as https in the limelight settings (and the Embed stack which behaved the same way). I’ll do some more digging in the SimpleTix console to see if I’ve missed anything there but I think it’s something their support team will have to sort.

Thanks to you both for checking it.


#8

Here is the non SSL link in the page that you are importing:


#9

Yeah I can see where the error is but I don’t set that page specifically anywhere. I set the store (which is coming through as https) and create the events in their Admin console, but I’m not setting that specific URL anywhere that I can see. I think the SimpleTix IT folks just needs to update their code


#10

Yep, it looks that way if they are generating the link.

You will have our GDPR compliant friends in a unbridled panic with that, non SSL links to external sites. I’m surprised that someone hasn’t visited your house and carted you off yet.


#11

Well I only soft-launched it last night. Add in time zone difference and travel time and the GDPR version of the Peaky Blinders* should be arriving shortly.

*I’ve only just finished season 2 so no spoilers


#12

Another question @tav The company is working on the SSL issue. I just checked it on mobile, though, and the iFrame doesn’t seem to be scrolling. I was sure it was before but I’m not positive that I checked it (I may have just done the browser Dev tools, in which case, it scrolls fine using my mouse wheel).

Have I missed something in Limelight or is this also originating with the iframe?
Edit: here are my settings. I tried changing from ‘scale to host stack’ to ‘no scaling’. That allowed scrolling, but created a big empty space at the top…


#13

Update: I tried it with Embed (Stacks4Stacks) and it seems to work fine on mobile. However, I like the more responsive height setting of Limelight/Sections Pro on desktop. So I’m just using Agent for now.

Having said that, if there is anything I’ve missed in my setup via the screenshot, I’d be interested in knowing.


#14

Try turning off show host content

Other than that though, scrolling is possible in a number of ways depending on how you size the container and / or the limelight content. Have a look at the Limelight Hotel demo - this pages all scroll when imported.

You can always send me a simplified project page if you are still having no joy with the above.


#15

Sounds good, I’ll give it a go this weekend