Image Fit (Source) warehousing option

@habitualshaker – In version 1.0.3 there is a checkmark for warehousing, but no way to input a URL? Am I missing something?


I see that happen sometimes (not with any particular stack repeatedly) - if you click away from the stack and then back on to it then the relevant settings should appear.

1 Like

Indeed, this way, warehouse URL setting appears. I am able to input the URL, but instead of an image I get blue square with a question mark. The URL is definitely the correct one, because it works in another stack (as a background in Container Plus).

I can’t replicate an issue with that @fapkogi. Definitely worth checking the link again. If still no joy then please DM me the project file.

I have seen this many time and I assumed it was a Stacks bug. As Stuart mentioned it seems to be easy enough to recover but it may be a more complex issue and requires a RW restart.

I have seen this with other stacks UI components such as switching from a URL to a Colour, and the colour well doesn’t appear as expected. Clicking on a different stack and then back to the problem one corrects the UI issue for me.

Strange. I started a new sample project for you, @habitualshaker . I copied the page with Image Fit stack from my original project to the new one and the image appeared out of the blue. But it is still invisible in the original project.

I restarted RW, following Gary’s advice, but the image still isn’t visible in the original project.

Yet typical :)

Perhaps @Isaiah could comment on that, as this must be a Stacks 4 bug?

I have also seen other strange behavior in various stacks. For example, input boxes in settings lose their focus right in the middle of typing.

Back to Image Fit: when I replaced the stack that failed to show the image with a new instance, it worked right away, but only in Edit Mode. When I switched to Preview, there was still no image.

I can’t replicate any issue with the stack - warehoused or not / edit mode or preview. Happy to have a look at your project if you are able to share.

1 Like

Thanks, Stuart. I wish this would solve the problem, but apparently, this works completely randomly. At some point, the image has popped up in Preview. I don’t know why it was failing before and I don’t know why it works now. Must be one of the mysteries of the Universe…

1 Like

It could be a RW Preview cache issue. In other words your RW browser is retaining content from a previous Preview.

Could be. I have no idea.

One thing for sure, I know only two apps on the Mac that are so deeply riddled with bugs. The other one is Audirvana.

1 Like