Issue with PHP Event Calendar from phpjabbers

In a move to leave GoogleCalendar behind, I bought phpjabbers EventCalendar - I had some good experience with them for another script - to replace a handful of clients’ online calendars. However, I am facing a strange issue which so far could not be solved by phpjabbers themselves.

I installed the script on three different ISP with different PHP versions but all with minimum version 7.4. and a RaspberryPi 4 which I use as a LAMP replacement if you like. For the Pi I had to install BCMath beforehand.

Installation went smoothly without any error messages. I could add categories and events. However, when calling the script, it does not show the calendar events, just the main bar on top. This is the case for all SSL certified domains (let’s encrypt).

For the Pi I use two different DynDNS addresses, one with, the other without SSL. The one without does show all calendars from all different ISP when I call the script in my RW testing page. Very strange I guess.

Does anyone else experience the same or a similar behavior for any of the PHPJabbers scripts?

Cheers, Juergen

Which script are you talking about? I use lots of their scripts, never had an issue like this. Send me a link to the script in question.

I mean this script: PHP Event Calendar | PHP Calendar Script | PHPJabbers

I just noticed, they use Let’s Encrypt, too. So, this should not be the issue…

Oh I use that one on loads of sites. I call it Timeslot Manager and forgot it’s called events Callander.

Here is a demo: Time Slots Booking Calendar by

Works fine for me every time.

Got a link to a page where it’s not working?

Not working with SSL

webgo Germany:
Infomaniak Switzerland:
Pi 4:

Working without SSL:


The Pi might be a bit slow, though ;-)

Is the script on the same domain as the install?

Sometimes yes, sometimes no

Is the sometimes no the instance that doesn’t work?

Going back some time, browsers started to get picky about the script and the install being on the same domain.

On the Pi, all of them work, whether local or not, provided there’s no SSL

I would start over with a fresh install on a server, not the Pi. Out the script and the install on the same domain. Ensure the paths in the setup are correct.

Try that and see if it works.

What you are trying right now, ie. Lots of different instances on different setups is going to make troubleshooting confusing. So do a fresh install and work only with it.

I did that already. It was only on the Pi when I noticed it did not work with SSL… however, I give it another try and let you know

I’d avoid the pi and use your regular server. Makes trouble shooting easier for others.

You are trying to load from a non-SSL http source to an SSL https location. @TemplateRepo is correct, it’s better to have scripts, fonts etc. in the same domain.

Sorry, but I don’t agree. In this case, I installed the script according to the instructions into a subfolder of the root. As I said, installation went smoothly, and adding categories and events was ok. Just the front-end does not work. I did not change anything in the script or themes. So, the script tries to load form none SSL URLs.

I’m checking the script files now, full of http:// calls

I checked the relevant files and changed the http: instances to https: manually… no clue why the phpjabbers people did not notice when I mentioned the SSL issue to them.

This calendar works now:

@TemplateRepo and @Geoff Thanks a lot for your inputs. Finally the issue could be solved.

I will certainly go back the PHPJabbers people