Launch Limelight Map from link inside OpenStreet Map Stack?

I don’t think this can be done, but hoping some clever spark can prove me wrong.

Go here:

On load, a LImelight lightbox will open with a map in it. I’ve set it to load on open so you can see it.

Now close the lightbox and you’ll see an instance of @Jannis Openstreet Map with the various Spanish Costas as pins. At the moment, if you click a pin then click the name of the pop you get taken to a Google Map of that Costa. I want that title link to open the Limelight map.


In the OpenStreet map on the page, where does it get the Google Map links from?

A regular link box…

Not trying to be your “clever spark”, but have you tried entering a class to open a Limelight following the normal Limelight link guidelines?

Erm… can you elaborate?

And please, be my clever spark, I just want to get this task done!

1 Like

Well the first think is not to put a URL int link that you don’t want to go to.

Instead do this below:

And create a Limelight Lightbox (Google Map) with the Unique ID of ladyboyzareus and the location for Google o and it.

That don’t seem ot work sadly, I had tried something similar already, although had the setup slightly wrong.

I’ve added back to the page your method:

Click the Azahar map link…

The settings for which are in this image…

It’s not opening the LL map lightbox, which has the following settings…

Directly below the map is a text link in a launcher to launch the Azahar map, that works fine.

Where am I going wrong?

My initial thought was that should work, so I tried it and it works fine for me in a Source page. I.e. a link to a Lightbox map using your Link settings and same Limelight setup from what I can see.

So strip the page content back and find what’s wrong.

Never used Lime 🍋 light

OK, I’ve started to nail this down…

Gary is right, his method works, but not with the link inside Openstreet Map stack.

I’ve updated the page, the map link for Azahar uses Garys class method, it don’t work. Below the map are two text links, the first uses a Limelight Launcher, and works. The 2nd text link uses Garys method, and also works. But this method won’t work in the OSM stack link box.

@Jannis any ideas?

Thanks chaps for the help so far.

Looking at the links in Inspector…

This is the link inside OSM

<a href="javascript:void(0)">Costa del Azahar</a>

This is the manual text link

<a href="javascript:void(0)" class="azahar">This text launches it using Garys class thingie. </a>

The class seems to be getting stripped out of the link in OSM.

First guess would be that the links in the map are not present when limelight binds the class names to its click event trigger.

Would that cause the class to not be present in the Map link?

Now seen your last post and yes, that would not work as the class is not present in the HTML

Cheers. I think this is something weird going in the OSM stack. Over to @Jannis :-)



See the post above…

Is this something weird in the OSM map?

How did you enter the link in OSM?

I thought it might be the open in new window thing that was killing it, but when I removed the tick, the class was still getting stripped out.