Launching certain Limelight content from a link on another page...?

On a client site I’m currently working on I open different Limelight contents inside a Sections stack. You can see this if you go here… Schadstoffe | GAEA Umweltconsulting …and then click on one of the items in the Limelight Bar in the right column.
Now the question: Can I jump from another page of the website to this page and at the same time open a certain Limelight content (for example “Flammschutzmittel”)? I think for this there would have to be added certain code to the URL, but all my tries so far failed… @tav?

You can launch a Limelight from the url by using the query string ?ll= so for example

Here is a direct link to the lightbox example I did from the RM forum this morning


Tav, weirdly for some reason when I open the project file or the link from the RW forum, the modals on the two bottom buttons do not open. However they do open when using the link you posted above.

So the modals don’t open with this link:

but they do open with when I close the initial launch of the modal and then use the buttons.

A bit confounding. Any idea as to what may be going on with that?


Only the top 2 buttons have anything associated with them - the ones that say Open Info…

The bottom 2 buttons are just there to duplicate the layout on the site the OP posted.

Similarly, he had 4 columns of pictures and in the info panel - I just left them empty and did the first column.

That’s what I thought initially, but on the link that opens the modal on page load, the bottom two buttons actually do open a modal if you close the initial modal and then use the buttons.

That is because they are default Foundry buttons. Unlike BP2 or Foundation buttons, they don’t have a javascript:void(0) action associated with them when you drop them on the page.

They therefore just reload the current page which has the query string in the url - hence the lightbox opens again.

Really, it is not semantically correct to use a button as a link but that’s another discussion completely.

1 Like

OK - understood. Thanks for the explanation and thanks for the project file. Your demo projects are always a great resource to have on hand.

You will also notice that I inserted javascript:void(0) into the URL of the two buttons that I do want to open the Limelights with. This is again because we don’t want the default action of the link to happen, instead we just want the custom class to trigger the action;.

Had we been using a ButtonPlus2 we would have set the type to Button rather than link - which is semantically correct for an action rather than a navigation link. Foundry buttons are not really buttons at all, they are just links with a background and padding and have a role=button to tell screen readers to treat them as buttons. In terms of operation though, they are merely links.

I did notice the

and appreciate the explanation as well as the explanation of the workings of an actual button and a Foundry “button”. Good to know the capabilities and limitations incase one runs into an issue when trying to use a Foundry “button” as a button.

Thanks @tav, but that doesn’t seem to work in my case (or I’m just too stupid). If you have a look at my link… Schadstoffe | GAEA Umweltconsulting …and at the screenshots I do have one Limelight on the page (ID = schadstoffe) and 11 Limelight contents with different Launch IDs. As an example I want to open the content of the Launch ID “flammschutzmittel”. What would be the link for this?
Schadstoffe | GAEA Umweltconsulting doesn’t work (of course…). Any hints?

Have you got any other stacks on the page that may be intercepting the url query string?

Try a little test of your limelight on a blank test page and see if that works as a first test.

Ok, I just uploaded a test page with only the default F6 Site Styles and my Limelight-/Sections-Setup:
A link like test | GAEA Umweltconsulting still doesn’t work. But to my understanding it just cannot work, since “flammschutzmittel” is a Launch ID (this should be opened with the link) and not a Limelight-ID (which would be “Schadstoffe”). I think I need a combination of both, since in the URL it must be defined which Limelight to open and with which Launch ID (from which I have several on the page)…

The query string should contain the content ID, the setting named Unique ID in the stacks content child (not the name of the lightbox (limelight id)). It does not matter which Limelight it is on the page, it is always the content that determines the launch name (just as it does when launching via a class name).

Try an even more simple example. Add a new limelight to a page with just a single stacks content child. Leave everything at the default settings and preview in Safari (no RW preview).

Once the page had displayed (blank), add the ?ll=lightbox1 to the end of the URL in safari so that it reads` or similar (your port number may be different).

Hit enter - does this refresh the page and show the lightbox correctly?

If so, which it should, then there is something about your other Limelight setup.

In this case you could simplify it to try and find out what is causing the problem. If you get it cut down to a single content child and it still doesn’t work then I’ll take a look at it.

Thanks Andrew, but still no success. Tried it locally in Safari and also uploaded the page here:
The link test Copy | GAEA Umweltconsulting should open the lightbox, shouldn’t it…?

You have a JS error on that page, looks like its something to do with F6.

This works fine for me

Also - can I just check that your Limelight is up to date at v1.1.1

Thanks for your ongoing help, Andrew. Limelight is up to date (v1.1.1) and even your test file doesn’t work for me in Safari. I’m on Mac OS X Catalina 10.15.7 with Safari 14.1.2…

Have to go to bed now and will have another try tomorrow. Good night…

Thank for this information of not using button as a link.

1 Like