Limelight / Vimeo / modal issue (user error?)

I have an issue that is probably user error or related to the fact that I’m using a really old version of Limelight (1.1.1, April 28, 2021) because I still have to support IE11 on our corporate Intranet due to legacy software (we are finally ditching IE at the end of October!). I can’t supply a URL because the Intranet is behind our firewall, but you can see the issue here. https://vimeo.com/manage/videos/754771150.

Basically, I have a bunch of Vimeo videos set to open in modals.

  • I’ve tried javascript:void(0) & javascript:nolink() {with the corresponding code}, but both have the same effect: they open a new window and the video plays behind it. Close the window and all subsequent clicks work fine. Open in new window is not checked and the only custom attribute is “class” and “value”
  • When I use a hashtag, nothing happens on the first click; all subsequent clicks open the modal just fine.
    Any ideas? There’s no strange stacks that I can think of on the page, nor any extra embedded code that I can think of.

Your link is just to the Vimeo original - which is not rated and so needs to be logged in to watch. Obviously this won’t show the published page issue.

Limelight will not open pages in a new window - its a ligjhtbox within the current page so I’m a bit confused as to the problem.

to launch a limelight, you simply need the class name. If you are using a button stack (perhaps Foundation or BP?) then make sure it is set to Button and not to link in the settings.

What about now- I changed it to all audiences? https://vimeo.com/754771150. And, I can’t figure it out either. I’ve used Limelight in every site I’ve built - for years. I’ve never seen it do this before (which is why I’m guessing I’ve done something wrong).

I simply have text links. I’m currently using a hash (but I’ve also tried both JS items) and just a class to open the Limelight. As for the Limelight settings, the only thing I’ve altered is the close gadget (size and position).

I know, the class and Launch ID in the screenshot don’t match (all 15 do match up).

screenshot_8965

There is absolutely nothing in Limelight that opens content in a new tab but I cannot tell what is happening from the video without access to the inspector and the page code.

What happens if you remove the lightbox class from that text link without changing anything else does it still open a new page?

Naturally, your comments got me to thinking of a way to better show you what’s happening…and I can’t reproduce it. I wonder if it might have something to do with server caching. It’s a really old page- and I updated the method of displaying videos from Expose to Limelight. At any rate, all three methods are still not working correctly on the Intranet today, so, I pulled the page out, duplicated it and published it publicly. All is working fine. https://sandbox.mediapressions.com/ (On the Intranet, the noLink and JS-Void pages are, I promise, opening a new page…and the hashtag page still does nothing on the first click, only). Really strange.

EDIT: I even changed the URL for the NEXTGEN page on the Intranet…I’m still getting the same results. Oh well, our people can just click twice the first time.

I see the issue, but if I remove the target="self" on the links then it seems to work fine for me. I.e. the link instantly opens the Limelight.

How do I do that, though, Gary? I’m not adding it- does RW add the target automatically?

Not sure without seeing RW Link to remind myself. I am away from my Mac at the moment. Will report back as soon as I can check.

target="_self" means open the link in the current tab/window NOT a new one.

There is quite a lot online about IE not honouring the target attribute properly but that doesn’t explain why it is only on this particular page.

Also of note though, the correct syntax is target="_self" - note the underscore @dave’s code does not have that in it.

What version of RW are you using? Mine is not adding that with 8.9.3

Thats a bit of a red herring I’m afraid. If you make any change to the link HTML then it starts working correctly. For instance, try changing the # for javascript:void(0) and it also works OK

1 Like

@dave Looks like you’ve changed the links to the no link() function on your page and it appears to be working now.

I’m using RW 8.9.4 I will try reverting to 8.9.3 in the morning and let you know what happens. As for it working correctly using javascript:void(0) - not using Windows and Edge. The first time I click any of the Limelight links, a new (empty) tab opens up at the same time the video/Limelight opens up. The new tab covers up the video. When I close the tab, I can see the video. All subsequent clicks work perfectly. It’s only the first click that’s screwed up…regardless of whether I have a hashtag, or either of the js codes in the URL space. Really weird.

8.94 is just 8.93 with an advert for RW classic - it won’t make any difference.
What version of Stacks are you running?
I can’t imaging where that target attribute is coming from - its not even correct attribute syntax.

I was not referring to javascript:void(0) I was referring to javascript:nolink() which refers to a function in a custom script tag.

Now when I look at the page, the links are pointing to # again.
There is something very weird going on.

I have all three types of links on that site:
https://sandbox.mediapressions.com/ (hash)
Concur Videos (nolink, with your Nolink stack installed only on this page)
Concur Videos (js-void)

I’m running Stacks 4.2.5, dated August 6th

I figured out what the issue was. As I thought, it had nothing to do with Limelight.

The issue was that the text links were originally coded to open the videos in a Reveal Lightbox using the “Launch External” checkbox. When I moved the videos to Limelight, I simply changed the URL to javascript:void(0) and the attributes to class and a trigger for each (screenshot higher up in thread). But, Rapidweaver was apparently remembering the Launch External from before - so even though I cleared the cache, republished all files, cleared the cache on Cloudflare, etc., the links were still firing the launch external from long ago. When I replaced the list of links with a new Paragraph Pro and created all new links (everything looked the exact same), the page works as expected.
screenshot_9029

2 Likes