macOS 12.3 + Stacks and strange preferences

There is a bug in macOS Monterey 12.3
If enough preferences are written quickly the macOS preferences daemon just entirely hangs. This causes all sorts of strange things:

  • Stacks asks for serial numbers
  • Bookmarks are missing in Safari
  • Contacts can’t be changed

The issue can be triggered when Stacks running it’s background updater.
This will be caused by any version of Stacks.

But I have a nice workaround for it.
I posted it on the RW main forum – but it’s buried – and I’m not “moderated” there so no one sees things. So I’m giving it another go over here.

I could really use some feedback on this one.

The sooner you can give it a shot the better. Once I get a bit of positive feedback, I won’t wait too long before releasing this to everyone. So grab it, install it, test it, and send me feedback.

Technical details about this problem and why this fix might work to follow in the next post.

How to get it

Just download. Unzip. And double-click to install.

What you should test

  • Uncheck the Use single thread for stack updates checkbox if you enabled it. (see Joe’s post above).
  • Open the Stack Updates window and click the Check Now button.
  • Quit and Relaunch Safari. Check if your bookmarks are still in place.
  • Quit and Relaunch RapidWeaver. Stacks should NOT ask for your registration number.

Report Back

  • Did it crash? If so, save the entire crash report and send it my way.
  • Did the update check seem to work?
  • Did it get any faster (I think that might be an added bonus of this little workaround)

Where to send feedback

Feel free to post here, or to reply via the various threads, tweets, and emails that you’ve sent over the past few days. I’ll try to keep an eye on it all.


Right now!
Since the macOS 12.3 update and it’s buggy user-preferences daemon are affecting a lot of people, I won’t wait very long before sending it out.

But I’d love feedback, no matter if it works for you or doesn’t.


I just sent a crash report.


I have not been affected by this problem (running 12.3), I only have a few stacks.

I have installed the update and run a ‘Check for Updates’ and everything worked the same way it always does.

I Quit RW and re-opened and had a crash.

More details:

After installing the Stacks beta, RW re-started itself and I ran a Check Updates and everything worked fine

I quit RW

Restarted RW and when I selected my existing project it ended immediately

Project is a small 3.1Mb project file

I restarted RW and it now appears to be ok

I can rerun Check Updates without any issues.

I wonder RW needs to be Quit completely rather than restarting itself.

@isaiah @joeworkman Thanks sooo much for solving this issue for us all in record time! The Stacks beta works like a charm, no issues anymore here! 🥳🎉 I also raise my glass to @jacksona for his detective-work on this. 🥂🍾


Happy that I was able to help! 😀


Works for me. No crash, no weird behaviour after checking updates and it does seem faster --is that the free placebo effect? :-D
Thanks Isaiah!

It’s not a placebo effect. It really is faster!

This fix removes a few ssd writes for each stack update it checks. That’s just a few microseconds. But it can really add up if you have a lot of 3rd party stacks.


Yep, it’s faster. Startup speed has also increased significantly.👍