Missing punctuation letters in TAG links - POSTER STACK

Hello, can you help me?

I need punctuation letter in TAG links in POSTER STACK, Now is missing.
I have TAG: Křeče.
and link is now: https://www.picomineral.cz/blog/?tag=kee
but right link should be: blog/?tag=krece

how can i set up?

web: www.picomineral.cz

Thanks. Mike

Sorry, currently not possible.

When i download your TEST RW project and chande TAG to: čšťžýáí (in HOME page)
slug is:
and this is perfect… its ok for me.
(I tested this early as I bought the module)

but when i use POSTER it in MY project… TAG: čšťžýáí slug is: ?tag=n-a

I found a problem. when the page is in RW (in the computer) it’s fine …
slug is ?tag=cstzyai ----
when I export it to the server, the links will change to ?tag=n-a
where is the problem? what can i do?

I’m not an expert in this, but I had a similar issue (not with Poster) with some German characters (letters). I think it has to do with the encoding.

You could try using the Unicode character for the Czech characters. So instead of ř, try ř. You could also try changing the encoding on the RW page to Latin.

These are just some ideas, as I said, I’m no expert.

If it works, you can see the code list for Czech characters here http://pages.cs.wisc.edu/~bolo/travel/czech_chars.html

1 Like

If it works inside preview, and not on the server, it is most probably a PHP version question. I have to test this on the weekend and come back.

1 Like

hi and thx.
but its not working. i changed encoding and used ř

but this code page not transcoding to ř . still display likeř

ok, thank you. i will wait for your test.


It’s a difficult one related to PHP settings for character codes etc.

I have published now a new version 1.11.5 for Poster Stack (via inbuilt stacks updater) with an additional option to allow non-ASCII characters for titles, categories, and tags.

Please use with care, test thoroughly, and let me know if issues occur.


Hi Jannis, thx.
I did the test and the result is:

Slug is changed, but used non-ascii characters now - and some letters yes but some not - its not good for SEO still
For example:
TAG: čšťžýáí
new slug: ?tag=ľščťžýá%C3%ADé (“í” is not recognized still and other characters is with punctation)
the final result must be: ?tag=cstzyai (without punctuation, only “clean” characters - as in english :))

some other look at pictures:

thank you for your effort.

This looks like to be a browser issue now.

It works for me in Google Chrome: https://posterdemo.instacks.com/test/?tag=čšťžýáí
See screenshot below.

Also in Safari the correct non-ASCII characters are now inserted into the generated tag link, just the Safari browser changes some of the characters by itself.

1 Like

Hi, probably yes … in Firefox and Chrome is really ok.

but can you change slug to non punctuation characters? this would help to all browsers.
or add the ability to set my own slug for TAG and CATEGORY.

i thing that for SEO (link/slug) is better with non punctuation characters.

thanks, mike

I hope you understand that special character handling is a pita. There have been reasons that for a long time I only supported ASCII characters in tags.

It doesn’t matter how a link (href) looks like, as long as the display text inside is correct. Google Crawlers don’t execute or follow links like wrong browser implementations. Therefore it’s also not affecting SEO.

For example, take the link I posted above, copy(!) it into you clipboard by text selection (not right mouse click copy link) and paste it into Safari. This browser will automatically change all special characters to their unicode representation.

In order to be able to transfers most of the different language characters into an ASCII representation, I need to use another PHP library, and this will be done in a major upgrade of Poster Stack. There are even some languages where no translation table exists.

1 Like

OK, thank you for your help.
I will hope you change PHP library in future.
I will use the site as it is now.
Many thanks :)


Hello, you have something new in this problem?
Thx! Mike

Try to enable “allow non-ascii characters” inside the Poster Main Stack.

Enable “allow non ascii characters” is not the solution
10 months ago you wrote:

you will solve this problem?
many thanks

I see. I am more trying to allow all allowed URL characters to be included in the URL also.

I don’t think this is a SEO issue, and also I don’t think it is a problem.