New BLOG Project 30 - 8 variations on our own blog

Are you using the latest Sitelok version? I know a bug fix was included there.
I also fixed an issue on my side, though. As said, it should work.

Please upgrade to Poster Stack version 2.6.0. You’re still using 2.4.0.

1 Like

Thanks I’m modifying the code and also verifying I have the latest version. Thanks.

I fixed this Sitelok issue between 2.4.0 and 2.5.0 ;-)

1 Like

Oh ok. I seem to have broken things during the updates. I will report back a bit later once I’m running again. My RW8 crashed during the stack updates and once I got it going again and doing the updates, I’m getting a fatal error when I call up the blog page.

Sometimes restarting your Mac helps.

I tried. I think the problem is when I was doing the Stack update there was an update for Source and when I began the update RW crashed. So now when I try to open the Blog pages, I get the following error:

Fatal error: Uncaught Error: Call to undefined function getBoolean() in /private/var/folders/4f/t9y32drx3vg9zr1lyfzj7y_00000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/29372/document-0x7fd634b9dc70/RWDocumentPagePreview/blog/index.php:225 Stack trace: #0 /Applications/RapidWeaver 8.app/Contents/Resources/RWWebServerLaunch.php(175): include() #1 {main} thrown in /private/var/folders/4f/t9y32drx3vg9zr1lyfzj7y_00000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/29372/document-0x7fd634b9dc70/RWDocumentPagePreview/blog/index.php on line 225

I need to take care of some other business right now so I will have to take a look at whats going on a bit later. Thank you so much for the help.

Yeah, that’s a RW resources preview issue not copying the required files to the correct location. It comes and goes.

1 Like

Do you have any tips or suggestions on how I might resolve this? I reinstalled my Source stack since thats where RW crashed on update but that didn’t seem to help.

Try to reinstall Poster Stack (download from my.paddle.com)

1 Like

I have seen this type of thing many times over the years.

My tip would be to downgrade RW to the previous version, restart Mac, restore RW Project file to a pre RW crash version, check for Stacks updates and update one by one followed by a RW restart after each update, if there are stacks updates.

Generally going forward, save your project after every few changes and restart RW every 10 minutes or so. Only update RW if it is to fix an issue you are struggling with.

1 Like

I tried, wished it were that easy lol. I am noticing that the only projects that cause the Preview error are Poster related however.

Since doing the updates, I noticed that any project that uses Poster has the error on preview. Projects without it seem to be fine. Thanks for the help. Reinstalling Poster (downloaded from Paddle) didn’t help so I guess I’m going to have to try a previous version.

Can you preview in Safari, Chrome, etc.?

Please send me one of the projects with such an error as zipped archive.

I will try. Something is going on because previous versions are doing the same. I will see if I can get a clean install. Maybe remove all the stacks from the stack folder?

It’s doing it with any Poster project. I downloaded the Project 28 & 30 which I recently bought and they do it as well. Unfortunately this is a new error I haven’t had to deal with before. I do appreciate all the advice.

I will get back to you in a direct message.

2 Likes

No I just tried both Safari and Chrome. Here is the error in Safari opening the Project 30 file.
Fatal error : Uncaught Error: Call to undefined function getBoolean() in /private/var/folders/4f/t9y32drx3vg9zr1lyfzj7y_00000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/3847/document-0x7fbb7243fe50/RWDocumentPagePreview/index.php:481 Stack trace: #0 /private/var/folders/4f/t9y32drx3vg9zr1lyfzj7y_00000gn/T/AppTranslocation/8F7EB41F-2568-43FF-8DC0-29E93C45D511/d/RapidWeaver 8_9_3_latest.app/Contents/Resources/RWWebServerLaunch.php(175): include() #1 {main} thrown in /private/var/folders/4f/t9y32drx3vg9zr1lyfzj7y_00000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/3847/document-0x7fbb7243fe50/RWDocumentPagePreview/index.php on line 481