Not working icon support for parent navbar items

Looks like I am running into an issue with the NavBar component and its respective icon support. Using the MenuBuilder I want to add an icon to a top level parent menu item, like a world icon for a language selector. I switched on icon support in the theme as well as on the parent item, but the icon is not showing up. No difference if I use a menu text or not. Icons work though for items underneath the parent.

I am using the most current 335 of the UIkit Stacks. Is there anything I can do to fix this behavior?

Cannot reproduce an error, these are the steps:

  • Add an empty item to the top nav
  • Drop an Icon stack into that empty item

That’s all really, here’s my sandwich:

Thanks for the feedback. That might be another option to solve that, but I am currently not using the Icon stack, but I am referring to the icon feature of the Parent menu stack. From what I understand, this should be possible without using the Icon stack explicitly. Am I wrong?

In this case at the Parent item select Dropdown icon and from the library select your icon. I understand this can be confusing, in a future release I’ll probably remove one of the options for simplicity.

Duh, I should have figured that out :) Just for clarification, if you have a parent/dropdown, you can’t have an additional icon in front in case you still want to have the triangle as well on the right side. Then it would indeed make sense to remove the option altogether. Thanks!

Forgot to tell you that we can insert icons manually using these snippets:
<span uk-icon="icon: check"></span>
<a href="" uk-icon="icon: heart"></a>

1 Like

I have read all these post and I still cannot get the HOME icon to show in my menu bar. I used the same set up as in CANVAS framework, I enabled icons in style, but nothing.

In the Canvas project the Navbar is in Menu Builder mode, so the Home icon is an item on the the Navbar. On that item you have to enable icon and choose home from the dropdown menu.

Lucas, what worked was enabling “Icons” in the Themes Style, which I read somewhere in the forum. Thank you.