QuickEditor CMS

Another interesting new CMS stack solution just appeared on the block.

Just looking at that. I use Sentry (https://seydesign.com/stacks/sentry/#) on loads of sites. It was initially part of, or a spin off from Armadillo, then sold to Seydesign, which was then taken under the wing of Will.

For a while there Sentry was pretty flakey, but I assume once Will had it he fixed it up and it seems to be working fine again lately.

Not sure what Will’s plans for it are though, so be interesting to see how QuickEditor progresses.

It’s quite difficult to understand what exactly QuickEditor is, or rather what exactly it can and can’t do.

1 Like

If it works like Sentry, which I suspect it does, I’ve a video about it here: https://youtu.be/CLR-YDJnslI

It’s a video I made to explain how it works, I offer it to clients calling it “Simple CMS”.

I tried the demo but my changes didnt hold thru. I wonder if this is deliberate so that people dont mess up the page, but if you cant see it actually working …

This is pretty much how all CMS demos work as a result of people editing the content to inappropriate content.

I wondered how long it would be until someone made this into a stack. I obviously have no experience of the stack but I’ve played with the content tools library and it is nice.


yes I appreciate that, but if the reset could be 5 mins so that the changes could actually be seen. Or maybe I was doing something wrong.

For my own site I would like to know how to reset it too. I have a demo page with Joes TCMS on and I have to keep going to it to make sure it hasn’t been messed up when someone is trying it out. Could anyone tell me how to set a reset, say after 10 mins?

I guess that’s a question for Joe and he doesn’t hang out here.

I tried the QuickEditor demo and it worked fine but after a refresh it reverted back to the default text which is exactly what I was expecting.

The demo says that changes won’t be saved.

You need to set up a crown job on the server to replace the content with a copy of the original you have saved. There is a thread on WS about that. Have a search.

Bought this today to give it a try, but fallen t the first hurdles: The instructions/demo project is 8.1 only, this machine is 8.0.3.

It seems obvious, but added the admin stack to a page, now no idea what to add to the drop zones. Published the page, but no obvious way to log in.

Anyone who has got it, any pointers?

Maybe send 1LD an email and ask for a rw7 version. Or wind back time 6 months to when you upgraded to RW8 and give yourself a slapping.

On the glue again?

It’s for 8.1, so rolling back won’t really fix anything ya muppet.

I’ve emailed them, but wanted to get a play with it tonight, suspect it’ll be next week before I hear from them.

@steveb I’d love to hear about your experience using this stack once you get it going. I’m not expecting anything definitive from you until next week, but very interested in your observations. Your first experience obviously isn’t good, but that might quickly turn around once you know more.

I looked on their website for a tutorial about QuickEdit but did not find one.

I meant roll back time before you upgraded to RW8. 6 months to the day when RW8 was released.

No, there isn’t one.

I’m baffled as to how to get it started.

I assume you add the admin stack to a page, it looks like this…

No idea what you are meant to add to the drop zone. I added some text, and button, and even an image, but on the published page nothing is showing.

WFT? Are you off your tits on something? How will that help me open a project made for 8.1?

OK, getting somewhere.

On the demo site, when you click the “open admin” link ?admin is appended to the url, so just manually added it to the url of the demo site and I can now see a log in page.

Fuck me, this really should be so difficult!

EDIT: Giving up. I’ve got so far as being able to log in, and I can get the edit box up, but the content that was added to an edit box isn’t editable. I’m most likely doing something wrong but without even some basic instructions on the website and not being able to open the demo project, I’m screwed.

bought and installed (latest RW8), tested on a single page, it works well for me

1 Like

@Multithemes Maybe you can teach @steveb how to do things. It’s harder to learn new stuff when you’re on your 4th pint on a Friday night. :)

Often 1LD provides a sample project. Would have helped a lot in this case: just provide their sample page as a downloadable project.

1 Like