Rapidweaver Upgrade to 8.1


#21

Yes. I am running 8.1 final final final (20579)

Edit: final final final final final final

Edit 2: Latest available :-)

Edit 3: final final final final final final


#22

You sure it wasn’t final final final final final final?


#23

Pre 8.2 beta …


#24

Yes, unique to 8.1…


#25

The site resource copy into document or level in place radio button is just a rename/redo of the old make document portable Or unpack portable document buttons.

I’ve been running the 8.1 betas all along and have had no problems. I’ve been using the “new and improved” in RW8 resources quite a bit and had no problems.

I’ve always used the “make document portable” now called “copy into document” options on all projects.

I tried during the beta testing to recreate the issue people are having with resources and couldn’t get things to fail.

Be warned, 8.1 projects are NOT backwards compatible with 8.0x.

Realmac should have done what they did with RW7 to RW8 and copy the project file leaving the old project file untouched. Instead once you save a project with 8.1 it overwrites the old 8.0x file and makes it unusable for the old version.

Nothing a good solid backup plan, that way to many RapidWeaver users apparently don’t have would resolve.

Any data is only as good as the last backup


#26

All my stuff is on Dropbox, Add-ons and Projects, but discovered Dropbox reads project files as a folder. So I still TimeMachine my client folders on Dropbox


#27

Project files are folders. Only macOS hides the folder structure and displays them as unique files.

It is a macOS package.


#28

Yes, that I know, just didn’t know that Dropbox will read it as a folder, making the Versions feature of Dropbox not as useful.

I use to exempt my dropbox folder from TimeMachine but now I changed that once I realized the way it reads it.


#29

No issues here with 8.1 either.

Some of the earlier Beta builds were quite buggy and worth staying away from. But the issues have been resolved in the later builds.

I sense quite a lot of the issues some people are complaining of are self-inflicted - storing files in odd places or doing things in unconventional ways. And there’s always that percentage minority who believe backups are just something other people do…


#30

I have just started storing my RW projects on Dropbox as I now have a Macbook air to go with my iMac. Would this be considered unconventional? I’m only about 3 days in of doing it this way…

@paul.russam you do this, don’t you? Or is it just your add-ons folder?

I would have updated already (it’s always been pretty smooth in the past) if not for the incompatibility between 8.1 and 8.0.3


#31

I’ve had DB since 2009 and only had 1 problem (I think), it was an outage their end and was many years ago.
I store everything in DB, my documents folder is as empty as a politicians promises, my DB account is synced on 2 Mac’s and 2 PC’s and I’ve never experienced file corruption etc.
My main Mac timemachine’s which includes the DB folder and I individually back it up nightly with CarbonCopyCloner.
I also use OneDrive for the DMA stuff, it’s also synced on the 4 machines, TM’d and CCC’d


#32

Same problem. Updated because hype looked convincing but after too many glitches, went back to 8.0.3 as advised by RW but it won’t allow me to open any project that touched 8.1. Solution???


#33

I’ve kept projects on Dropbox for years. Had the odd issue in the early days but nothing to speak of for years. About a year ago I started to keep addons there too, never had a problem.

I work regularly across two macs, I will literally work on a project in the office, save it, wander to thf lounge pick up the laptop and carry on working in front of the TV.

I very often leave the project open on both by mistake, but I’m always super careful to close and reopen when this happens, so as not to create conflicts.

As I say, never had an issue since Dropbox got its act together years ago.


#34

I’ve had zero, nada, zilch problems using Dropbox with RW projects. Simple as pie. Almost all my resources (audio, video, PDFs, etc.) are warehoused. So my project files are typically 20 Mb or smaller. They sync very quickly via Dropbox.

The only problem I’ve ever noticed is if you shut down one computer before the sync is fully done. Otherwise … smooth sailing.


#35

Are you on 8.1 yet?


#36

The issue isn’t where you are storing your RW project.

The issue is where you are storing the files (resources), which you are using inside your project.

Portable document = all files inside the project: fine ✅
No portable project = files all over your HDD: possible problems with sandboxing 🚫


#37

I just upgraded to 8.1. I don’t use portable document projects as I want to be able to change a document without having it to replace it in resources each time. I have no reason to have a portable document - It’s a hobby and I have a full time job writing technical software - I don’t need to carry this stuff around!

Moving on - all my files are bundled under the one folder with projects and a corresponding folder with any non “warehoused” documents etc…

It asked once to nominate the folder. I chose the top level of this tree and that was it. I had one test project where I had resources scattered all over the shop for a test and it correctly identified where they were and just asked permission for each location and all was good.

So, in the end I have had no problems (did not use the betas though). But don’t get me wrong. I have a multitude of backups.


#38

Hi Guys

I greatly appreciate all the feedback and input provided.

Like many people I too routinely make several back-ups of all data (not just RW) both locally and remotely and use Chronosync and CCC to facilitate these back ups.

Noting the comments made re backwards compatibility of project files with version 8.03 I duplicated my project files into a RW81 folder and renamed the project file RW81.

I warehouse all of my assets to the point of excluding stacks if they do not provide warehousing capabilities.

I then proceeded to update my installations first on my MBP and then my main desktop machine via the RW updater.

The 5.5mb update downloaded - installed and updated the Sitemap Add-On all without issue on both machines.

I opened my RW81 project file and performed a local re-publish of all files.

Again all functions performed flawlessly.

It appears that the use of the simulator is far quicker than its function in 8.03.

Thus far my experience of updating has not been been as painful and arduous as I first envisioned - I just hope that the good things continue.


#39

It would be nice if it were that simple…

I basically save all resources directly in the project file, but I still get the error message for some projects and not for others. I even created a completely empty project and get this error message.

I think we have to wait for a fix and in the meantime we have to click “not now”


#40

Hmm… I never got this error in my various projects, starting from 8.1 beta…