Rapidweaver Upgrade to 8.1


#41

Just make sure the RW project file is not open simultaneously on both the MacBook and the iMac. Otherwise you might get a ‘sync conflict’ and the project file can become corrupt - with one version ahead of the other.

RapidWeaver project files are inherently quite fragile. Breakage can occur if the file does not fully sync - like the computer goes to sleep or is shutdown before a sync completes - risking some parts of the project file missing or being further ahead than other parts.

Ensure that you have a fast and stable internet connection that allows the changes to sync-back to Dropbox quickly and reliably.

I no longer have Dropbox installed on my computer, because I was growing concerned about all the ‘processes’ that were running in the background and the root-level access Dropbox needs to read files and install automatic updates. I now only use the web interface of Dropbox for sharing files with people by email.

To sync project files between computers, I simply use a flash stick. More recently I discovered my PlusNet router has a USB port on it, and plugging-in a flash stick (formatted in Windows FAT format) makes it work as a simple NAS (network attached storage) disk, that any device in the house and see and access files from.


#42

A quick test of RW8.1 on my secondary iMac…

Previously RW was not on this machine.

  1. DL RW 8.1.
  2. Duplicate addond folder which is on DB and give it a new name (did this in case 8.1 fecks up my working addons folder.)
  3. Duplicate recent project.
  4. Launch 8.1, don’t tell it about the location of the addons folder.
  5. Launch duplicated project: Get warning because Stacks isn’t installed (not yet using real addons folder). Expected.
  6. Close project.
  7. Point 8.1 to duplicated addons folder on DB. Select change folder, not move addons and change.
  8. Restart 8.1.
  9. Launch the duplicated project again.
  10. Project opened and previewed perfectly. This like most of my projects has only warehoused images.
  11. Close test project.
  12. Open the original of the duplicated project in 8.0.3 on regular iMac and add a drag and drop image. To clarify: I’m now adding a drag and drop image to an 8.0.3 project on a different machine to that with 8.1 on it. Project is saved as normal to Dropbox which is syncing with the secondary iMac.
  13. Close 8.1 on 2nd Imac.
  14. Reopen 8.1.
  15. Launch newly sync’d project with drag and drop image as per 12.

The new version with the drag and drop image opened fine and the drag and dropped image is displaying as expected.

So an attempt to break 8.1 failed. Perhaps it’s luck, or Will is right, problems are occurring in irregular setups.

If anyone wants me to test any scenarios with my set up here I’m happy to oblige if I can.


#43

And i suppose while I have 8.0.3 and 8.1 open on different machines of similar spec sitting next to each other, I might as well time the simulator…

Results… WOW! It’s now really really fast. I’d say it renders the same page about 90-95% faster than 8.0.3.

Obviously this is a pretty basic test, and there might be lots of factors in the background impacting this. But, on the 8.0.3 machine it’s redendering as normal, really slowly to the point it’s useless. On the other machine, it’s really fast and very usable.


#44

I guess to add, the machine with 8.1 on it is a year older than the 8.0.3, has less ram, is dual core not quad core, and has Parallels with Win10 running in the background with the processors almost always above 80%. So in theory, this speed increases isn’t down to the machine.


#45

I made some tests with RapidWeaver 8.1. and found that 8.1. must have a serious problem:

When I delete content or files in a project that content will not be deleted in the depth of the project package file. There will be relicts in the content.plist in the package root and in the resources folder. The problem doesn’t occur with new projects but with existing projects

I have tried to recreate this in RapidWeaver 8.0.3, but here the problem does not occur: Anything I delete from the project will also be deleted from the depth of the package. So it is definitely a problem with RapidWeaver 8.1 and we will have to wait for an update.

Since the way from 8.1. back to 8.0.3 is not possible if you have touched a project once with 8.1, it is better to uninstall RapidWeaver 8.1 until the problem is solved


#46

No need to uninstall 8.1. I have both 8.0.3 and 8.1 installed and just choose the one I want to use. My project file created in 8.0.3 I only open in that version. I’ve duplicated these and saved them to a different directory and use these with 8.1

In spite of the ‘multiple files’ warning and the plist issue, 8.1 seems to work well for editing, preview and publishing. I’ve overcome the ‘multiple files’ warning as described elsewhere in this forum.


#47

Having two versions of RapidWeaver on your computer is dangerous because 8.1 generates a new file format and there is no way back. And when you have both versions on the computer, you unwanted open an 8.0.3 project with 8.1. and have a problem


#48

This is the way I’ve always worked, having multiple Beta and release versions of RW, all separate with separate project files. Also, I duplicate my project files regularly and rename them with the date/file name.

Not dangerous at all and in fact a good way to work as long as you are disciplined.
2019-01-25_14-25-56


#49

There is now an 8.1.1 release out to address the issue of resources.


#50

Yep, v8.1.1 fixed the issues for me.


#51

I agree on the backups and using a copy to test out the upgrade. It’s good.


#52

There’s now a 8.1.3 release out. If you’re still having issues you might want to give it try.


#53

I had problems, RW 8.1 didn’t export my projects, didn’t even show any previews. When i disenabled “StylePlus” in PLUSKIT, everything seems to work fine again! I’m happy now!