RapidWeaver works in 10.15 public beta!

But… Stacks 4b doesn’t…

It’s always a laugh using the MacOS betas. Don’t worry it is installed on an old 2012 MacBook Pro so nothing was harmed or lost.

Beta 27 should install and run.

Currently it’s a very manual process to “notarize” a plugin to operate with Catalina. This notarization process is only a weeks old (for plugins like Stacks) and Catalina public beta only came out hours ago. Please give me a tiny bit of compassion here. I’m only one guy. 😔

1 Like

I know it is a very early beta and never expected it to work at all. I was very surprised when Rapidweaver started!
Don’t worry, it is months away from being released and even then I doubt everyone will leap to install it.

If it helps. The latest beta didn’t load.


It tries to get me to authorise it from the Security preferences but the reinstalls it and goes around in the same loop.

To be a bit more clear: Stacks 3 and Stack 4 are both Catalina compatible – but Stacks 4 cannot be installed (this is due to notarization – see below).

Update: give it another go – Stacks 3 and 4 should both be installable now.

And when I say “compatible” what that means is that it’s “compatible” – as much as the few days of testing we’ve all had with Catalina can determine – which ain’t a heck of a lot. It doesn’t seem to crash and I haven’t noticed any obvious problems.

About Notarization and Catalina’s New Gatekeeper

The issue is that “notarization” is a rather new thing. And notarization of a “code bundle” – what a plugin like Stacks is – isn’t particularly well documented, was totally impossible a short time ago, and changed very very recently.

Early versions of notarization required the “receipt” to be built in to an app or an installer. But Stacks isn’t an app and doesn’t require an installer. 🤨 But recently apple changed things a bit and now apparently allows the “receipt” to exist only on Apple’s servers.

Strangely this meant that the notarization tests I ran on Stacks 3.6.6 way back in April magically work now. Yeah… I guess? But no one bothered to tell me. LOL.

This change and its implications are all very new to me. Literally. I learned of this change and that Stacks 3 magically worked now only 4 days ago.

I’m still working on automating this notarization process so that it happens when I release a new build – but it’s complicated, can take hours, requires crazy one-time passwords, and more UNIX incantations that you can believe.

But as a stop-gap, I ran the notarization by hand on a bunch of previous builds. They’ve all cleared as of Tuesday June 25th at about 1am. So you should be able to install these Stacks versions:

  • Stacks 3

    • v3.6.3 (4180)
    • v3.6.5 (4206)
    • v3.6.6 (4224)
  • Stacks 4

    • v4.0.0 b27 (4674)
    • v4.0.0 b29 (4680)
    • v4.0.0 b30 (4685)

Future builds will be a bit spotty until the process can be automated. So if you see an update fail then give it a day and try again.


I have Stacks 3.6.8 installed, which hopefully passes as well. Does anybody know if RW7 is OK with Catalina?

I am still running Mojave with a mid 2010 Mac Pro, but likely to get a new Mac mini with Catalina before long. I was wondering if Mojave could be run on a new machine either from a VM or external drive, otherwise it looks like I’ll be keeping the Mac Pro with Mojave for as long as possible.