Repository 2 Question

I purchased Repository 2 as soon as I saw it. Brilliant! I am using it on a couple of sites, always as an upgrade from Repo 1.

Here is a minor issue: now I’ve created a new site, added Repo 2 as a fresh install - and can’t login!

Before I sound totally stupid, this has always worked first time in the past - now using the default of ‘admin’ and the hashed form of admin as the password it will still not work (preview in RW and on the site)

User: admin

Pw: $2y$10$21FlgZMq3t/cqILUshJDc.Kcsnx30pS9BnwpDV95waiD17ayOAopW


Hash generated by

Am I going mad this morning? It is quite possible!


Sorry to ask a dumb one - I’m going around in circles today and I have no idea why

Please check the PHP error log.

You configured the starting point being root of the domain + _repo

In addition, you configured the page of repository to be inside _repo

That’s kind of a double configuration.

Please change from root of domain to relative from page, and leave the input field inside repository stack empty.

Unfortunately I am not able to double check. If it’s also happening inside RW preview, it should be related to this.

Is the demo file working?

1 Like

Thanks Jannis.

Good news - Demo project is working correctly

I deleted and re-created the page, spotted the double config and resolved it. Now it is working if I use admin and plain text admin…

So it looks like I was being forgetful - I have been entering the hashed pw every time…because I use a PW app (1Password) I did not realise the pw on my other (working) projects was ‘plain text’.

Apologies for the panic and my being very daft. RESOLVED

1 Like

Apart from my own ridiculous mistake, I have to say how absolutely BRILLIANT Repository is…

So easy to use and extremely effective. I have been adding my own blog posts this way for several months and this week, I am going to take the bold step of giving my client access to her own blog, via Repository.

All her older posts are backed up, so watch this space!

1 Like