RW 8.1.3 Qube 5 custom background image


#1

Hi all,

I hope somebody knows:
I’ve been using Qube theme before with custom CSS code for background image but since update to RW 8.1.3 or maybe Qube 5 theme, it stopped working.

RW settings-code-css:

#background {
background-image: url(%resource(background.png)%)
}

Any ideas?

V/R
Costa


With RW8.1.3
#2

Do you have an image named background.png in resources?
When you select the new resources button, does the background.png look ok?


#3

yes
I’ve been using this technique for a long time!


#4


#5

Actually, I think it’s RW 8.1.3, but can’t really figure out how to fix it.
I just moved back to RW 8.02 and everything is back to normal


#6

Did you get any warning message about resources when you opened the project with 8.1.3?

In 8.0.3 under advanced is the project made portable?

There was a lot of problems with resources when moving to 8.1.x for some folks. Not sure what specifically is going on with your project, but you might want to let RealMac support know, I think they think all has been fixed.


#7

Yes, my project file is portable and No warning messages while on 8.1.3.
weird.
rw support might be able to look into it unless they think its all good:)


#8

I’ve tested this. It looks like a bug. Still around even in the beta.

RW is supposed to notice the pages you use resource macros and export the appropriate files (an image in this case) when the page is being previewed.

Using a macro in Settings / Code should export the resource on every page. It did in previous versions of RapidWeaver.

Tested in:
RW v8.0.3 👍
RW v8.1.3 👎
RW v8.1.4 (20621b) beta 👎


#9

thank you!


#10

I’ll take that back. Partially.

It’s a bug, for sure. But the reasons for it are not as simple as the image not being published. I suspect it may have more to do with the path of the image.

I was able to get it to work sometimes by disabling a specific setting.

Go to the Settings (underneath your pages in the left sidebar) and choose the Advanced item.

Then make sure the Consolidated CSS files is UN-checked.

If that doesn’t fix the issue, then you’ll have to type in the path to image manually (which probably isn’t too hard).


#11

Good Catch,
I’m guessing this has been reported to RM.


#12

it worked, but previews in RW have some lag, seems buggy.
Also after publishing website, there are some gaps in between generated page and browser window.


#13

even in RW.


#14

i reported a number of bugs about resources in preview when 8.1 first made the big changes. but that was many weeks ago. i’ve flagged this post to the guys again.


#15

thank you!