S4S file man cannot be viewed - perm set wrong!

I tried today S4S FileMan stack.

  1. the folder is created not in my planned for subfolder but in the root of the domain -> you have to add the subfolder in the relative path (although the publishings settings have incorporated this subfolder; which is also mentioned in the comments of the stack.
    The publishing path is:
    The folder to be created: bestandsbeheer3
    The note in the stack is:

But to actually create the folder you have to put the subfolder in the settings (relatie path):
The note says:

  1. The settings of the permissions is set to: 755.
    When I check via ftp, the actual permissions are set to: 340, and the folder is empty (no demo files).
    If you then correct this via ftp, and after the next visit of the webpage, the folder bestandsbeheer3 contains the demo files.