Sections Fix cross origin problem

Working on pretty standard site layout for the past couple of days and suddenly get a cross origin problem in RW while previewing (I use Firefox Dev edition - not Stimulator).

The banner is the problem: There’s a SectionsFix inside a SPro with HPro and ParaPro - no images - that refuses show. This only happened in the past couple of hours and the only major change I made was to add an AniPro to the SPro bg image. (Deleting it has made no difference.)

Checked in Safari, Chrome and Stimulator with the same result.

Deleted stacks, images, fonts - one by one. Same result.

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS header 'Access-Control-Allow-Origin' missing).

The cross origin error link doesn’t exist.

Image below shows the layout - nothing out of the ordinary…

Test page:

I’m a bit stuck now - any clues where this issue emanates from?

That error is coming from the Foundation duplicate page checker script.
SectionsPro or Box does not do have anything to do with it and they are the only places you could add a cross origin link to an image. Sections Fix does not even accept links.

The question is why is the dupe page check trying to go across origins? Have you got the address correct in the RW general setup?

Just looking again - it looks like you have put the wrong url into the address in RW or publishing settings. Look at the path in the error - it refers to the sand. I’d sub domain but appears to have an extra sandbox directory in the path as well.

I never thought it would be Sections - it’s combination I’ve used many times.

So I’ve deleted the server files, taken out the animation, got the url right (!) added another test banner with the same stacks. Uploaded anew… same problem.

(The only change to RW during the page construction was the Foundation update.)

When I use Foundation (very infrequently) I have seen this error more than once and just ignore it. It is always caused by the duppagecheck.

Other people have mentioned similar problems since the update on WS.

Is that error still there with just a site styles stack on the page?


This is the culprit:
.preload-wrapper #stacks_in_27_page0 {visibility: hidden;}

I fixed it by adding a class to SFixPro:
.showme {visibility: visible!important;}

A bit of a sledgehammer but I can apply it globally without worrying about the ID. Is there a neater solution?

That is not the culprit - that is the victim. The other error is killing execution of JS on the page and so the pre-load condition is never removed.

Ah thanks. I’m not wittingly casting aspersions ha ha!

I know you are not - I just want you to get to the root of the problem or else other things will also get broken by the lack of JS running.