Selfhosted Fonts - can't get BWD Scribe to work

Hi all,

one of my clients got one of the German (B…S…) notifications because of using Google fonts in the website.
Website is made with BWD’s stacks, Scribe mainly. Now I tried to change to “absolutely” selfhosted settings but I can’t get it to work.
Can someone please point me to the mistake I am making? Tried the links with .woff ending and without … no difference . RW is always loading the backup font, not the selfhosted one, either in preview or preview within a browser.
See screenshots…



Thanks a lot in advance,
Tom

Hi, which theme are you using?

And some important info about these Abmahnungen:

Cheers,
Jan

1 Like

Your URL looks wrong. It should end in Ginger.woff if the font file is called Ginger.woff.

Another way to load fonts is to add the font in woff into resources and then nstead of loading a URL, select Resources in the RW Link box and select the font directly from resources.

1 Like

You don’t need the extension - your first settings image is correct. Scribe adds the appropriate extensions as per the checkboxes you select (as described in the tooltip).

Don’t use the full font name as the family name - this is a CSS value and cannot contain dots. Just ginger would be fine. This just allows you to re-use it in other stacks.

The problem appears to be that the font is not at that address on your server, it is giving a 404:

I know your image above looks like it is there but the 404 from the browser tells the story.

1 Like

Thank you Jan!