Armadillo and New Server issues

Hello everyone, I’ve encountered a fresh issue and could use your help. I’ve recently shifted from my previous hosting provider, Fatcow, to a new one called Hyperhost. In the process, I’ve successfully transferred all my files, MySQL databases, CNAMES for URL redirection, and everything else necessary to ensure my sites operate smoothly.

However, despite moving the databases and updating the new details on @NimbleHost Armadillo Stacks and then publishing the site, my blog isn’t appearing as it should. I’d really appreciate any assistance you can provide on this matter. Here’s the link to the blog in question:

This is what I get when visiting the setup link:

What version of Armadillo do you have and what version of php is on your hosting?

CleanShot 2023-09-15 at 19.34.44
CleanShot 2023-09-15 at 19.37.48

The error says the connection to the database is not working. So either the settings you’ve entered aren’t correct, or the database isn’t up and running.

The database is functioning properly, and my settings are correct. The hosting platform’s technical support agent also reached the same conclusion.

Hi @albertkinng,

Please note that your password is visible in that screenshot - I’d remove it and replace it with with a version where the password is made unreadable.


1 Like



Thank you. This was presented as proof that the login information I provided was accurate. Any idea for solving this issue?

There is some more info in the displayed error message:

php_network_getaddresses: getaddrinfo failed: name or service not known

I suppose the web server (where PHP and your website is running on) is not able to resolve the dns address of the database. This could be of various reasons. I doubt Armadillo is responsible therefore, but the infrastructure.

Example: php - php_network_getaddresses: getaddrinfo failed: Name or service not known - Stack Overflow

1 Like

Perhaps I miscommunicated due to grammar errors, but I don’t seek to find a party to blame for this issue. Irrespective of whether the problem is with Armadillo, the server, or Rapidweaver that’s preventing the website from loading properly, I need to identify a solution to keep the page running after the server switch. In this regard, what steps might assist me? Should I construct a new database from the ground up? Is a server plugin update or installation required? Could utilizing other stacks be a solution? I’m confident that I’m not the only one transitioning between servers and managing to keep the momentum. As I lack expert knowledge in this specific problem area, I’ve come here seeking assistance. Please inform me if you unearth any information that might be helpful. Thanks again for taking the time for this.

IMO this issue has to be solved by your hosting company.

1 Like

@albertkinng , are the Armadillo pages and the database in the same server? If yes, then try using localhost or as host name in the Armadillo settings instead.

Often the credentials to login to databases are like user@server (you could check this with tools like, for example, phpmyadmin). The server part of the credential could be the wildcard %, so username has access, but if it’s set as artistnotes1-353033355822@someinternalipaddress, then it, won’t despite that the ip address could be the same where is pointing to. That is something the hosting company should have configured properly, as @Jannis wrote.

I’ve tried explaining it very very basically, you could read into the details in the MySQL documentation pages or a summary like this.

Anyway… give it a shot by changing to localhost or (the ip address of localhost) or the ip address of (you can try pinging it).


I’d like to publicly acknowledge @Jannis for his remarkable dedication and support. All systems are running flawlessly now, and I’m truly honored to be part of such an accommodating community. I also appreciate everyone who offered assistance and shared their expertise to help in resolving the issue — thank you all. The core problem lay with the new Hosting Provider, but thankfully, they managed to unearth a solution.


I’m curious to know what was the cause and/or the solution.

Edit: call me cranky, but communities like this work because we share problems AND solutions. Just getting your sh!t fixed and running off isn’t really motivating me or others to (continue) to help (you). Sure you thanked the people involved, but the feedback of what works and doesn’t is required fuel for those who like to fix stuff and help.

Edit 2: fixed typo


@Konfuzzious, as Spanish is my native language, I rely on a translator to understand your posts. The translation of your previous post seemed offensive to me as it seemed to criticize my failure to share how others solved my issue. If the negative tone was merely a translation error, then that’s fine. However, if it was intended, I find it unjust as I have always addressed you with respect, professionalism, and patience.

From what I gathered, any software utilizing MySQL requires the host name, database name, username, and password to access the database. Simply adjusting these to match my new server’s details seemed to resolve the issue. The root of the problem appeared to be that my new host failed to provide these crucial details, leading to this entire predicament. Unfortunately, I do not have more information beyond this.

Moving forward, I would appreciate it if we can avert any unwarranted negative comments due to things I did not do. Thank you for understanding.

1 Like