Armadillo - impossible to do fresh install


After having had trouble with Slim errors after updating to Armadillo 2.9.10 @NimbleHost I tried to do a fresh install on an empty site without any other stack used.

I use RW 8.9.3 - Stacks 5 - Blank Theme. The web server is on PHP 8.1.

I tried several re-publish all, emptied the root directory, but all in vain.

The finale setup process does not work, i.e. the tables are not installed and the the page remains blank afterwards.

I also tried PHP 8.2 - same result.

I am a bit desperate for a handful of sites I support using Armadillo as CMS / Blog. In case their provider finally updates to the latest php version, I risk the sites not working anymore.

Any hint, idea what could be wrong is highly appreciated.

Best, Juergen

Hi @Juergen - I will try to reproduce and follow up in this thread; this is a scenario I’ve not yet specifically tested (fresh install with v2.9.10 under PHP 8.1 and RW 8.9).

1 Like

Hi Jonathan @NimbleHost

Thanks for looking at this. It’s bizarr somehow. I tried it on two different web servers (Infomaniak in Switzerland and webgo in Germany).

I would really like to continue and extend the use of Armadillo as it is very versatile and easy to use for less experienced end-users. Hope you find the time to check it (I know you are very busy ;-))



Thanks for your patience @Juergen - I have been able to reproduce this issue, and as you’ve discovered, this is specific to fresh installs of Armadillo, and involves some initial queries that are attempted when Armadillo detects that the database configuration file is present and it is able to successfully connect to the database.

I am working to add some more verification steps to these initial queries to make sure errors don’t occur when this happens prior to setup being completed. I’ll keep you posted when a fix is ready for release.


@Juergen I’ve just release v2.9.11 which fixes this install issue under PHP 8+, as well as a potential incomplete install issue that could occur under PHP 7.4. Please let me know if this resolves the problem for you.


Hi Jonathan @NimbleHost

Thanks for the update. I could do a fresh install of the new version on two different web servers with a PHP 8.2 configuration. However, when trying to post or modify the settings the SLIM error occurred again.

Creation of dynamic property Armadillo_Solo_Content::$lastEdited is deprecatedFile:

/my-path/rw_common/plugins/stacks/armadillo/core/model/Armadillo_Content.phpLine: 27

After switching back to PHP 8.1 the SLIM error disappeared and posting or changing the settings worked again.



Roger that, thanks for the info @Juergen - will take a look at this as well.


@Juergen This is now fixed, and v2.9.12 released and the update available via the Stacks Library.


@NimbleHost Thanks a lot, Jonathan! now, everything’s works as expected, under PHP 8.2., too

Best, Juergen

1 Like

Thank you very much. Now it would be safe to use Armadillo for the foreseeable future?

Best Regards

Hi Jonathan @NimbleHost So far, everything works fine with PHP 8.1. and PHP 8.2. installed. However, when setting display_errors=on I get these lines of messages:

str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in /mypath/rw_common/plugins/stacks/armadillo/core/displayContent.php on line 612

Warning : Trying to access array offset on value of type null in /mypath/rw_common/plugins/stacks/armadillo/core/displayContent.php on line 608

Warning : Trying to access array offset on value of type null in /mypath/rw_common/plugins/stacks/armadillo/core/displayContent.php on line 608

Just to let you know.

Best, Juergen

Many thanks @Juergen - yes, I did see these and am currently working on them. Since they don’t appear under “normal” conditions, in the interest of expediency I went ahead and pushed out 2.9.12 so you and others wouldn’t need to wait for those fixes.

1 Like

Hi Kent,

I’m biased, of course, but my answer would be yes. Hopefully others will have a chance to chime in with their perspectives as well.

1 Like

Information: Armadillo 2.9.12 and RapidWeaver 8 (Version 8.9.4 (20901))

I want to update one of my websites with the latest updates.
In the past I had no problems but since the latest update when I try to preview the page an error is shown.

Fatal error: Uncaught Error: Class 'Armadillo_Language' not found in
Stack trace: #0 

I’m very reluctant to publish the website or will this error not effect the published site?

Hi @Sonderpa - that particular error suggests a file is missing. Since this is happening in preview I wouldn’t be concerned. If you want to make sure things will work before actually “publishing” you could export the site to a folder on your Mac, then upload that folder to a sub-directory on your live site, a location only you know the address for. Then you can access the site in that sub-directory to confirm things work as expected.

OK thank you, I will give it a go. I will let you know how it coming along. With your attention to your stacks, I feel confident it will work for the foreseeable future.

1 Like

For the site I am trying to install Armadillo, the hosting company is not listed, so I used the “other” setting, but nothing shows up on the published site. The hosting company is Ibrave. Do you know which setting to use for this company?

Hi Kent. So far I noticed, ‘other’ works fine for any other provider. Did you try to re-publish all? Did you do the second installation step after calling the page with Armadillo’s initial stack?

Hej Jurgen. Thank you I got it to work. I actually used the Nimblehost settings. Then I found the admin page in the RW-common folder. And I made a test blog post and it works like a charm :-)

1 Like

Performance! As it is now, I checked the loading speed and other parameters of the blog page. And it is super fast and I am super delighted because the speed and size of the resulting page are crucial for this project.
I am so happy that I now can provide my friends in Burkina Faso with a working system that can expand with all the other features Armadillo provides out of the box.