Help with stacks disappearing form addons folder

I tried to update Stacks so I could install Splider 2. Stacks would not update. I tried dragging it into the addons folder and now RW can not find the stacks plugin, I even tried reinstalling the older version and nothing happens. When I search for any stacks they all show up in dropbox/downloads, not in the library.

Of course all my sites are built with Stacks

Is there someone who I can pay to help me straighten this out?

Useful steps to try one by one are:
Restart RW
Restart Mac
Check RW for updates, install if any and restart RW

You don’t need to pay for something you can pretty easily fix yourself.

You may have your addons installed in more than one place – each for a different version of RW. Do not try to place addons directly into any folder, because RW may be looking for them in some other place.

The best way to install addons is to drag them to the RW icon in the dock. Most likely, that is the version you are actually using.

But before that, I would do a clean re-installation. To be safe, first create a folder on your desktop. Find all your addons, wherever they may be installed on your system. Drag them (not copy, just move) to this newly created folder and keep them there, until you make sure that your new installation is not missing anything.

Then, open RW’s Addon panel and make sure that RapidWeaver is managing the location of your addons.


Only then, drag your addons onto RW icon in the dock, to install them properly.

As Gary said, relaunch RW. Sometimes restarting the Mac may be necessary, but less likely. Install all updates, make sure nothing is missing, delete (or, better yet, archive) the folder with old addons.


Thanks, Gary, I had done everything suggested except restarting which worked and I was able to reinstall stacks. I always tell my wife to restart when something goes wrong, but you know how that is.

Thanks, Rob, that was over the top help. Luckily Gary’s suggestion to restart helped. I had already done the rest. And I always tell my wife to restart when things go wrong. Duh.

I had thought of doing your suggestion but was afraid to do it. With your instruction, I would have if needed.

For about a year now, when I install a stack by dropping on the dock icon, it never works. I have to use reveal in finder for an installed stack and place the new stack there. This time it did work to drop the stack plugin onto the icon in the dock, but not for the splider2 stack I was trying to install when all this happened. I had to do the reveal in the finder process. I do have addons set to Managed by RapidWeaver. I’ve been using RW since the first version, but I’m an amatuer and only build for myself.

1 Like