Limelight - content not scrolling

Hi @tav
I have this website (
There is a pop-up window (Limelight) which is opened by a (Joe workman’s) CTA stack.
My problem is that the content doesn’t scroll. You can reproduce this issue by reducing the browser window or on mobile.

Could you tell what is wrong?
Thanks in advance.

Something is causing the browser to report the wrong height. The lightbox is therefore sizing to a much greater height than the page.

Could you try just putting that lightbox on a separate page and opening it - see if the problem still exists. If so then please send me that test page and I’ll look into it immediately.

If it works on a separate page then it is going to be a case of half splitting the page until we isolate the problem but let’s take that as stage 2 if we don’t get anywhere with the above.

You can see the lightbox here: Test | Anita Picardi
I’ve been adding to the page: Styles, CTA, BP2 Defaults, Limelight, Menu…
All is working well until I add more than one container (with content).

I can’t really tell what exactly is breaking things on your live test page so I’ve made a little test project . It has 2 containers inside the limelight and 2 containers outside the limelight.

At the moment it is working fine so could you show me on that project what change will break it.

Lets leave CTA and BP2 out of it for now (unless it they affect things) - I’ve got limelight set to open on page load and I’ve also turned on ‘stop page scroll’ so it should be an accurate representation of your situation.

Downloaded, thank you.
I’m adding things and all is working fine at the moment.
I’ve simplified my test page, now is working. If I add another container or change the content of the outside containers (i.e. Markdown for Scribe), the scrolling stops then.
In case it helps, here’s the link: test-no-scroll

Thanks for your file. I think I’ve found the problem and it seems to be Scribe.

If you change the Scribe stacks for Foundation Text stacks then the lightbox scrolls correctly.

I’m sure that this will be a simple fix for Scribe but I won’t be able to look at it until Monday. I have a good idea what could be causing it so it shouldn’t take long to get it sorted.

Thanks very much for your help in tracking this down, your file was invaluable.

1 Like

Update - it is not Scribe. I can reproduce that same problem on a blank page by adding more than one Stacks Markdown stacks to the page. It seems like it is something to do with the Markdown processor as Stacks Text or any other stack do not seem to cause the problem.

More when I know what is going on…

1 Like

Further update - I don’t think there is a problem with Scribe or any Markdown - I think your project file was somehow mangled.

I’ve just rebuilt the page from scratch with a new Limelight and pasted all your stacks back onto the page and it scrolls properly. The only other thing is that with the current settings, I don’t think you need CTA - you could just use the LL Open on Page Load checkbox but perhaps you intended to change CTA to once per session which would require it?

Here is the working version:

1 Like

I am pleasantly impressed by your dedication, effort and speed in solving the problem.
Thank you so much, Andrew.

Just a little reminder to support Tav’s fine work and dedication: