Need some help publishing my website

I spent about two hours with earlier today figuring out the right settings to even get RW to start uploading the files to, and it eventually gets to the end and says ‘unable to upload, check your publishing settings.’ I’m not sure where to go from here, but I thought I’d ask here before I get on to again. I do have Transmit if that’s going to make the job any easier.

I have 12 different sites with - never had any problems. Let us have some more info / screenshots (mask password).

Depending on what you have set, you can try changing the connections to something lower than 6. If it is starting to upload but then times out, you can likely rule out errors related to path, login/password, etc.

However, as Dave says, quickest way to get help is to show your publishing setup (without passwords visible) as well as what message you get when you click the Test button.

Edit: also mention your Rapidweaver version number.

Thanks for the replies! I have the latest version of Rapidweaver.

here are my settings at, this is what the support guy told me to do:

The test is positive, strangely. But when I try to upload it goes right to the end then comes up with an error message.

The path looks odd. Try clearing the path field and use the “Browse” button to select the folder to publish to.

That’s the path the support guy at told me to use. When I browse I see this:

I’m just trying it again at ‘average’ speed. It takes a good 30 minutes as I have a few files on the site.

That worked, but when I type my website’s address into my browser I just see this:

I see this:

I have found slow to refresh - it can rake a few minutes sometimes - not always though.

Yes, it’s working Ok because I’ve just been in touch with support at and I had to use’s file manager to manually move all the files into the root directory. It seems that when I want to update my website I will have to do this each time. Is that right?

No - you have the root directory for your site wrong - it is probably a folder called www - You’ll need to change it to the correct directory in RW Publishing settings.

1 Like

I’m a bit lost with what you mean, sorry!
This is what file manager looks like at, now it’s all working ok:

and this is what my publishing settings are in RW:

What do i need to change, please?

Do just hit browse and choose the folder all the files are in?

Click ‘Up one directory’ - the name of that folder is where your files need to be published.

1 Like

When I hit browse it doesn’t say ‘Up one directory’ just this:

Though I guess that’s still ok, right? ‘Up one directory’ is just at’s file manager…

Are you using RW on a desktop or a laptop? - you’re not far from me to take a look.

on a laptop

If you have some spare time and transport, I’m 15 minutes north of Gloucester.