Quick Editor Admin

Does anyone here have any experience with ILD’s Quick Editor cms.
I’m getting some very strange behaviour when using the admin login. If I enter the admin login details and click on the Log in button it opens up on a completely different page on the site to the one I need to edit. However if I enter the login details and just press enter instead of clicking the button it works correctly.
Has anyone else experienced this behaviour?

Hi pixelart, I’m also using QE a lot for smaller and also for more comprehensive sites - but never heard about this… A bit more infos about your project may be helpful. What version you are using? Jon from ILD is very attentive - give him a hint and a bit of time;-). Always best service for me.

@Roger Thanks for your reply. Here’s a link to the page:


If I click on the admin link at the foot of the page and the hover your mouse pointer over the blue Log in button I get a link to a different page on the site:

How that has been picked up I have no idea, but after filling out the login details and clicking on the button it goes to the page above.

Hi @pixelart - buy the way nice sites…

but what I see is this:
looks like a correkt > QuickEditor - LogIn:

but on :

Unknown LogIn:

It seems, you’re using two different Editors…?
Could it be?

The unknown logins you mention are for Total CMS. I can’t see how this would cause the button issue though. As I mentioned though it works if I don’t use the admin button and just press the return key.
Another thing of concern though is that the password is visible within the pages index.php file.

ok, there is surely a reason, but why do you use two different cms/editors? There is certainly a mutual influence…
well, i am not a programmer but i looked at your extensive collection (58 different ones and some as legacy) of stacks - QE is now at for me and a lot has changed - maybe an incompatibility…?

1 Like

Hi @Pixelart,

The problem is an overlay. It puts two invisible boxes on your screen. One that covers the password field and one that covers the button.

Clicking the first one leads to /contact-us and the second leads to /find-us. So when you click in the password field, you actually click the overlayed box. and if you try to click the button, you actually click the second overlayed box.

You can see for yourself: in Safari, hover over the password field and right-click, then select “Inspect element”. You’ll see that Safari doesn’t highlight the Quick Editor Admin stack, but the actual culprit: a stack called overlayMenu.

Try removing overlayMenu from the login page and everything should work fine.


I would have thought the overlayMenu would work with Quick Editor as they are both by ILD. The problem with removing the overlayMenu is that it is used throughout the site. It’s a shame ILD doesn’t use this forum.

Are there any z values you can change on the Overlay menu stack? or Quick Editor?

1 Like

gut erkannt;-) gut erkannt;-)

Now on mac and to my surprise I also have the Overlay stack, as well as Quick Editor.

Tried a test page with just those stacks and a text stack, no issues. Tried different stack orders, still working exactly as intended/expected.

Might be another stack on the page causing the issue?

Did notice in the page source that there was a LEGACY next to the OverlayMenu stack entries, though the version of 2.02 is current. Are these from the v1 of the Overlay Menu stack, and perhaps need to be replaced with the v2 Overlay Menu?

Thank you everyone for your input, it is much appreciated. I had a reply from ILD in which they sent me the newest version of Overlay Menu and it has fixed the problem.