RapidWeaver 8 uninstall

I have started having problems with RW 8 and have tried uninstalling it but there always appears to be some lingering files left over. For example when I thought I had got rid of the old installation and reinstalled RW the “Welcome to RapidWeaver” popup screen appears still showing all the recent projects which hints that I have not completely got rid of everything. Also all the stacks reappear.
Does anyone know of a way that I can completely get rid of RW and all associated files so I start afresh?

Drag RW to the trash and then empty the trash.

You’ll need to also uninstall various files in the library such as preference / container files.

This page offers instructions although they are also selling an uninstall package: Proper Steps to Uninstall RapidWeaver for Mac

@Manofdogs Hi Len, thanks for your reply. I have already tried the Mac Remover mentioned on that webpage but the same problems still reoccur after I uninstall then install a new copy. It clearly isn’t removing all files. I did try deleting the library files, at least I think I got most of them.

AppCleaner is free and does a good job of removing Apps.
It has been around a long time and is my preferred utility for removing files from your hard drive.
I use it just to find related files too, for troubleshooting.

Yes, App cleaner will also find the preferences file for the RW App and deletes it.

@chuckb Thanks for that. It works much better than my 2 paid apps AppZapper and Mac Remover. The problem is when I install a fresh copy of RW8 it is still finding my Stacks and Plugins which I think are the cause of my problems.

@Jannis But how do I get rid of of the plugins and stacks as RW keeps finding them and I would like to do a fresh install of these too?

Select inside RW “open assets folder” and delete them.

@jannis Thanks as ever.

1 Like

Hmmm. Since Apples new default APFS File System, where & how everything is organized is more confusing to me but follow Jannis’s advice and everything should be deleted. I might suggest a complete shutdown and not just a restart following the removal steps if your problem removing files continues…

@Jannis When you say “open assets folder” are you referring to the “addons” folder?

@chuckb After trying both yours and Jannis’s suggestions I managed to get a clean install. However it hasn’t solved my problem which is that of the stacks updater not working. I thought a clean install might have helped because when I created a new user on my mac and installed RW plus stacks the stacks the updater worked perfectly.

Yes, addons 👍


Is RW ticked in your System Preferences > Security & Privacy > Privacy box?

@Geoff No it’s not in there at all.

Add it and Mac OS will give RW permission that allow the updates to download within the app.

This is now common in Mac OS and all to do with security - a pain, but you only have to add it once.

You should also add RW to “Full Disk Access” and “Files and Folders” if the first step doesn’t add it automatically.

Finally, best to restart your Mac.

@Geoff Tried that but the updates are still not being recognised.

  1. Run Check for Updates
  2. Update All
  3. Reports All Stacks are up to date

When I check the stacks that are supposed to be updated nothing has changed.

Also I don’t have the “Files and Folders” option you mention.

Tried @isaiah but still not replied as of today 26/05/21. Wish everyones support was as good and swift as yours!