RW7 project upgrade to 8.93 -> error Content.plist missing

Hi all,
I needed to load an old RW 7.x project into RW 8.9.3
RW8 Upgrades the RW7 file to a RW 8.9.3 file… great!

But when i try to load it it gives an error:

I check both RW7 and RW8 files by “Show package contents” if there was a missing Contents.plist file.
But there seams to be no difference in both folder structures and files.

Is there a solution for this problem?

Thanks in advance,

René Schaap - Connecting Media

Sorry to hear you’re having trouble with your project. It sounds like there might be an issue with the original file. Have you tired opening it in RW7? Does it work?

You can download RW7 from here if you don’t have it on your Mac.

Let us know how you get on.

1 Like

I tried in on RW7… no success
I have several backup-ed files from the same project… all do not load.
Last time i used them (2018) there were no problems with this project at all.
That made me thinking… i updated last year to Stacks 5. This non loading project was made with Stacks 4 installed … that is the only thing that really changed. Can that or other new Stacks be the problem ?

Don’t think so, it really sounds like the file might have got corrupted. Can you send it over to and we’ll take a look at it for you!

1 Like

‘The file’ is not one file. I tested versions from even RW6… they all have suddenly this problem. I do not believe that all these files and backups are corrupted. I will first look further in the Stacks4 / Stack5 difference. When that does not solve it i will send you a file for sure… Thx for the help so far. Much appreciated!

No problem. If you don’t get to the bottom of it, drop support an email with the project file — also include a link to this thread so we know what it’s related to!

1 Like

RW projects are no files, they are folder and file structures, as you already mentioned. I see in your screenshot, that the path of the project is underneath a mounted volume, correct?

Maybe there is an issue with the mounted drive? I do not think it is an online synced folder? Did you try to copy the project to your desktop and opened it from there?

Definitely not Stacks plugin related.

Hi @Jannis , Indeed it is files and folders. And that’s why the error is weird. I tried to load it from different drives… from a NAS by network, from and external SSD and by the internal drives… even on different computers. I just tried it from the desktop…same error :( They all fail on this project. While all my other project just work fine. Maybe it is something with rights… I will try to dive into that part now… Thx for the Help Jannis!

I will… thanks so far!

Yes, if the file visible in the screenshot is actually contained inside the file, and content is available inside the file, it might me a permission problem.

By chance, were these files ever stored on Dropbox or any cloud service that was not iCloud?

No, they were never stored in the cloud. Only on internal harddisk and NAS

Ah, then probably the NAS is the culprit. In which format is the NAS formatted?

You should thinks that, but the file also does not load from an internal harddisk. I always had run this Rapidweaver files from internal drive… it never failed before. I have other Rapidweaver files running smoothly on the NAS btw… never had a problem with that. What you think a NAS can corrupt in a Rapidweaver file?

I’m no expert in this topic; but when the NAS would be formatted in some Windows format I could imagine that certain Mac-files (which consist of several files like the packages of RW project files) could get ‘damaged’ by that non-Mac-native file system on the NAS. And when the folders on the NAS and your Mac are synching back and forth in both directions I could imagine that this could eventually trigger problems. But as I said: I’m no expert in this field and could be wrong of course…

1 Like

Thx for the reply @wolf . The NAS is not windows formatted. And when i read a backuped file from the internal disk… all same problem. Did not have time past weeks, but i will dive again into it soon. Keep you all posted about my findings.

1 Like

Does anyone know of a “NAS Storage Device” that can be formatted with NTFS or FAT32?
I have never seen such a thing…

Long ago, I had a Windows NT Server 4.0 Services for Macintosh…
it worked great with AppleTalk.

It doesn’t matter how the drives in the NAS were formatted. It’s the operating system inside the NAS that’s causing the issue.

The problem here is that RapidWeaver projects aren’t files in the traditional sense, but so-called bundles. A bundle is a directory, filled with subdirectories and files, that is treated by macOS as a single file. It’s the same way how macOS handles apps.

Bundles are pretty much a macOS exclusive way of working (there are smaller, niche OS-es that do bundles, but most OS-es are alien to the concept). Products like a NAS generally run on their own little OS, which may or may not be familiar with the concept of a bundle (as it’s such a niche way of working).

If a NAS-OS doesn’t handle the bundle properly, it can become corrupted. This means that macOS no longer knows how to interpret the bundle, and the application (RapidWeaver in this case) can no longer open it.

How and why it becomes corrupted is a bit unclear. My guess is that the NAS-OS is handles some files in the bundle differently from the rest of the bundle, which means the contents.plist is no longer accurate.

The same thing happens on certain cloud storage solutions (although iCloud is of course safe, as it’s mac oriented), and I’ve seen it happen on SANs too (again because an external OS is handling the bundles instead of macOS).

The only way I know how to fix it, is to try and find a backup of the project file and manually extract the contents.plist from that:

  1. Look the backed up bundle up in Finder
  2. Right-click (or control-click) the bundle and choose Show Package Contents
  3. The Contents.plist should be right there in the root of the bundle. Right-click (or control-click) on it, and choose Copy
  4. Put it somewhere accessible (like on the desktop)
  5. Now copy over the corrupted project file from your NAS and store it on your local Mac
  6. Right-click (or control-click) that bundle and choose Show Package Contents
  7. Drag the contents.plist from step 4 to the root of this bundle and choose to overwrite it if macOS asks for it

If the backup that you source the contents.plist from is not too old, you might get away with this. If the source version of the project misses pages or resources that the newer project file does have, you’ll have to reconstruct those.