Stacks "jumping" to in-view when selected in edit mode

I’ve been seeing this a while, but never realised what was causing it, today the penny dropped, and it’s really bloody annoying. Can I stop it?

I think this is an S5 thing.

If you select a stack in edit mode that isn’t completely in view in the edit window, perhaps only the top half is in view, and the bottom half is off the bottom of the edit window; it jumps up the page, to get all the stack and its content in view.

It’s really off-putting, and means the page is constantly jumping around.

Does anyone else see this, and can it be stopped?

And today’s lesson is look at Stacks prefs before posting!


Yes, I noticed that too – after Stacks upgrade to v.5.

Thanks for sleuthing out the cause of this phenomenon, Steve. This must be a new feature and a new setting in Stacks preferences?

Yes, it is.

Not sure I’d call it a feature!

I genuinely can’t understand why anyone would want this to happen. Nor, why it would be default on.

I’ve spent hours* in the past trying to work out what was causing it, assuming it was a stack on the page (a la the float to top of page issue).

In the end I just accepted it as an annoyance.

It was only today that I spotted the pattern: it only happens when some of the stack you click is outside the view area of the exit window.

  • well, ok, not really hours.