TIP: Getting RW projects that won't sync over iCloud to sync

I’ve no idea why this works, but it does!

If you use iCloud to sync RW projects across machines you may from time to time discover that a project just won’t sync. No idea why, it just won’t. A fix I’ve worked out will resolve the issue, but does require you have Dropbox syncing over the same machines.

  1. Move the project that won’t sync to dropbox.
  2. Go to another machine that syncs both DP and iCloud and wait for the project to appear in the DP folder.
  3. Add the project that has now sync’d across via DP to iCloud. It should now start to sync no bother.

I’ve no idea why A. Some projects won’t sync on iCloud, or B. Why first syncing them across seems to “fix” them, but it does.


What if you just add a text file inside the same iCloud folder where the project is saved, on the other Mac? I had the experience that just the syncing down on the other Mac is not started. This should not be a RW issue, just a iCloud sync issue.

You mean adding another simple file to the folder to sort of “kick-start” the syncing in that folder?

Nope, tried it, for me never works. If I add another file to the folder it syncs no bother, but the RW project that refuses to sync still doesn’t sync.

The only files I get this problem with is RW ones. I suspect it’s something to do with the fact they are not a single file, or summit, I dunno. Al I know is so far, the above method is the only thing that seems to get them working again. I’ve even tried adding the project files to the iCloud folder directly, so to speak, in the browser, still won’t sync.

It’s like something in the project get’s messed up and iCloud won’t “see it”, but syncing it via Dropbox “fixes” it.

I’ve also tried syncing it first over various over cloud services, but only DB seems to work for me.

This is a unique problem to me either. I’ve sent projects that won’t sync to others and they’ve had the same problem: They won’t sync to their iCloud either.


Sometimes this can be caused by attributes on a file or files that iCloud doesn’t like.

  • Open Terminal and type xattr -c make sure there is a space after the c and don’t press enter.
  • Then drag your file into the terminal window - this will just fill in the correct path name to the file to save you knowing the full path.
  • Press Enter

It may then be worth dragging the file out of the iCloud folder and then back in again.

No guarantees but this has worked on several non-syncing files for me (including but not exclusively RW files).


I moved to sync.com (the free version) because I was having the same problem with iCloud AND Dropbox. I did find that if I took the project file out of iCloud to a local iMac folder, waited for a few minutes, and then moved the project file back into the iCloud folder that it immediately sync’d. This issue has caused me to lose updated changes to a project because it hadn’t sync’d completely on the one machine. Sync.com has worked out very well for me. Can get 5gb free, plus 1 go extra after going through a Setup tutorial with them. I saw this issue on a different forum where others were experiencing the same issue.

Plus one for sync.com , I moved to it earlier this year exactly because of these iCloud problems. It now works perfectly just like Dropbox used to before Catalina

What is the sync.com syncing software like in terms of resources? Dropbox is pretty bad, OneDrive was ridiculous, iCloud… I’m not sure as it’s pretty well hidden, but it doesn’t seem to be overly high. Given it’s baked in to the OS I’d suspect it’s very light.

I do not notice it working in the background, while I am working, but there is a free version to try it out

Just found another project not syncing, and unfortunately that didn’t fix it. Before I tried your tip i duplicated the file, in case it all went Pete Tong. Weirdly, the duplicated file did sync no bother.

What this is starting to tell me is there issue here lies with the RW file, not the syncing services. If it was just DB or one of the others having the issue I’d say it’s poss not RW, but given it seems to be them all, barring perhaps Sync.com you have to look for the common factor. And that’s RW.

I honestly don’t think it is anything to do with RW - a RW file is just a folder at the end of the day.

I have nearly 1.5 TB synced on iCloud over 7 machines and I see this problem quite often (but considering the number of files) with a very small proportion of the content. It is certainly not unique to RW files.

Here is my theory.

The strength of iCloud sync is also its minor weakness. It uses very little system resource and CPU compared to other services but it seems to be consequentially less aggressive in seeking out changes - by that, I mean that if it misses a change at the time for whatever reason then that file is left un-synced. The solution is easy though, either reset the attributes, move it off iCloud Drive and back on, move it to a different folder and back again or duplicate it (as you did).

The alternatives that I have tried all munch through CPU time and generally seem detrimental to performance. DropBox, OneDrive and a few others I’ve tried all do the same to varying degrees. Perhaps sync.com is different, I’m doubtful but I haven’t tried it. I use OneDrive for backups but I don’t have the shared folder on my machines to sync. I just use Arq to back up.

For me, the occasional drag of a file there and back is a price worth paying but maybe for others it is not.

Is this something you do manually? Or is it automated (in a way that’s different from syncing)?

I’ve recently switched to iCloud as well but might keep our OneDrive subscription for the windows users in my house and this seems like a good use for the extra storage space.

Automated using Arq which incidentally is brilliant!

I also use it to backup to AWS and a few other places as well.

1 Like

Arq is great. Did you go to v6 @tav? I did but think v5 is/was better.

If only you mentioned that in your original post…

@habitualshaker Yes I did but I only installed it on one machine and then reverted back to 5


I use Syncovery for cloud backup. It’s super clunky, and really complex to setup, but once sorted its solid and really customisable. One price for all machines, so pretty cheap.

Back to the syncing issue… Another project suffered the fate this morning, and somethings just occurred to me… Whenever I “fix” things, either by the method described above or duplicating it etc. once I open it again after it’s finally sync’d, I always get the missing resources thing at launch. It’s normally the favicons, open graph or logo images that are “lost”. These would be about the only resources used in my projects as I warehouse everything.

Thinking back, this has been a constant: ALL syncing services seem to lose the connections to resources, or the resources themselves. Does this not point to an issue in RW and the way it’s referencing or storing images?

By the way, “save images in project” is always ticked.

I never use resources (spit) so I couldn’t comment but it may explain the fact that I almost never get any problems except with the odd user file from a support ticket.

1 Like