Yuzool Checkout Stack 2 update / SCA

Pleased to see this stack has been updated - thanks to @yuzool for doing this in good time.

In basic terms it appears to me from reading the documentation, that you now need to do rather more than previously i.e.

  • Activate client integration in your STRIPE dashboard
  • List the domain(s) that you need to work with checkout
  • Add your Product(s) to the Stripe dashboard
  • Ad your Stripe generated Product SKU and IS to the Checkout stack in RW
  • Create a Plan for any Subscription in the dashboard and add the ID to the RW stack

The reason I’m curious is that SCA integration recently released in Machforms v 12, only requires the Machforms installation to be updated - none of the work in Stripe Dashboard gets mentioned at all.

Anyone started with this who can shed some light?

All of which takes a few minutes … it didn’t take long to build this real live site or the demo

That said, each integration is different so they may have done it a different way. Some republishing of RW pages might be necessary in some cases


Hi all,

I’ve just purchased Checkout 2 only to discover that it no longer includes Custom amounts…only Fixed or Subscription amount settings.

I wish Michael @yuzoolthemes had highlighted this in the purchase notes…the stack has lost one of its main features!!!

Beware before purchasing if you rely upon Custom Amounts.


That’s a real pain. Just upgraded to implement exactly this feature. @yuzoolthemes is custom values going to be added back?

Yep…feel your pain @Manofdogs

I’ve been trying to implement Checkout2 with Stripe but for the life of me I just can’t get the Stripe checkout to pop up.

Followed Michael’s doc instructions included with the updated stack but don’t know where I’m going wrong.

The Checkout 2 button is appearing on my website but will not then lead onto the Stripe card checkout page.

I have enabled Stripe Checkout in my Stripe dashboard then created a test product.
Copied and pasted the sku code into the stack.
Then used my live key and copied that into the Publish Key section.
I have then republished all to my website.

But can’t get Stripe checkout page to come up.

Stripe help page talks about webhooks but your docs don’t mention webhooks. Do I need to create a webhook?

The domain name for Checkout client integration, should it be the domain name where the Checkout2 stack is located? So therefore https://rapidwebsites.net/payments/payments-aud/ or should it be rapidwebsites.net as shown in the Checkout2 docs example?

Thanks, I would appreciated any help or advise from all you wonderful RW people.

Cheers Scott

Hi Scott,
Could you please refrain from double postings in both forums? Thanks.

1 Like

Sure Jannis, just removed from RW forum.

In fact, I’ve sorted the issue. It seems that the stack does not integrate with Stripe immediately. I had to wait for the product and settings to go through the grinder at Stripe.

It is now working, so will delete my post.


1 Like

? 😉

which URL did you use?

Yes, well…that expression may be different now…😳

be put through the wringer - to be subjected to some ordeal, difficulty, trial, to undergo an unpleasant experience.

Hi Len,

Used rapidwebsites.net but it is all good now.

It seems like it just took sometime for the product to be activated on Stripe.


Looks great Scott:

Custom amounts may come later but the important part was getting SCA ready for 14th September

The features were highlighted on the pages:


But yes it will hopefully be back @Manofdogs

Yes just use the root domain like in my demo site:

I’ve also added https://www.peekhq.com for example in testing. Either of those will be fine depending on the way the domain is setup (and will allow any sub pages to run the Stack).

Also Webhooks are not necessary - please follow the manual :)


Hi Michael,

Great, thanks. Very good to hear Custom amounts will make a return.

Stripe payments is now working great…but…not on touch devices.

Well, the buttons are appearing on my iPhone but when I click on the button it doesn’t redirect to the Stripe payment page. It’s working lovely on the Mac but not on my iPhone…weird?

I’ve also tested with the Stripe code pasted into a html stack to create another button £95 item and same thing. Button appears but does not click through to the Stripe card entry page.

So a Stripe issue??..I just don’t know??

Page link https://rapidwebsites.net/payments/payments-gbp/

I’ve created 2 items, one with your Checkout2 stack the other just a html stack with the Stripe code for that sku item.

Tested on both Safari and Chrome on my iPhone.

Any thoughts…??

Thanks everyone for ideas.

Cheers Scott

Works for me with iPhone.

Hi Jannis,

Mmmm, thanks for testing for me.

Was that on Safari browser?

I will to a hard reset on my iPhone and test again.

Thanks Scott

Hi Jannis,

I’ve done a hard reset on my iPhone and still not working for me. The buttons appear but will not click through to the Stripe payment page.

Tried again on both Safari and Chrome.

If anybody else reads this post, could you please do me a huge favour and see if the purple buttons click through to the Stripe payment page on your touch device.


Many thanks Scott

Just tested both ‘website deposit’ and ‘hosting’ on iPhone SE running iOS 12.4, Chrome and Safari both linked through to Stripe no problem.

The buttons don’t however have any colour change when clicked so don’t feel like they’re doing anything - particularly if connection is slow.

Hi Len,

Thanks so much…mmm…still not working on my iPhone 6plus iOS 12.4.1

Yes, noticed no colour change too…which is a little off putting as you don’t know if it does anything. I’ve tried on both home wifi (fibre) and 3G and still not linking to Stripe payment page.

I’ve hard restarted and shut down Safari and Chrome on phone and nope, doesn’t help.

I wonder if there is a security popup setting on the iPhone?

Thanks again for your help


It looks like the JavaScript is overruled by another stack or frame. Can you make a blank site with just the button and nothing else to test?

Hi Jan,

Ok, have done a new page and only have the 2 buttons on it.


I’m still having same issue…not working on touch my iPhone device.