Armadillo blank page - broken in RW8/9 with Foundation 6

Have contacted Nimblehost…nothing back.

This published the first time correctly, no problem…now its a blank page whenever the Armadillo setup is present.

Is previewing perfectly…theres been a number of F6 updates in the last fortnight…the moment i remove the Armadillo stacks and setup (which is working perfectly in the current site, set precisely the same) the page publishes and i at least can see it instead of all white.

Would really like some help, would rather not throw even more money away on Stacks - altho to be honest i might be better to ditch it, It’s already a complete PIA to setup and maintain.

yes i know that if setup incorrectly Armadillo can result in blank content, this is not that.

The content of your news.php page does only contain some header data, nothing else. I don’t think it is F6 related.

Pinging @NimbleHost so he’ll notice this post.

1 Like

Nimblehost did post and reply here a couple of weeks ago, also he did mention that he had some significant sounding health issues.

1 Like

Vice versa question, if you remove all the F6 stacks and theme (use a blank or simple theme) and just leave the armadillo stacks, do you still get a blank page?

yes thanks well aware, unfortunately that is not the case in Rapidweaver. Previews perfectly, does not publish correctly…obviously.

will try that too, good idea…we’ll know who the culprit is then, tbh pretty sure it is F6, only thing thats been updated furiously over and over.

Then i can be ignored by Joe too. Honestly im at a crisis point of wondering if Rapidweaver is a sunk cost…systems that rely on components have to be furiously tested with every combination first…ask any audio or video app developer.

Try a publish-all, if you have not already. This often fixes broken things as other files can be updated, but not necessarily publish.

done done done. no difference. even deleting the directory and republishing, same blank page. Joe is saying its some php error.

I assume that this is a typo since I have been helping you on the RM forum. I think you ruled out F6 as being the culprit.

1 Like

Exactly, it must be a server side issue.

Not as yet, appreciate the help but i’ve lost count of the number of times ive emailed your support and got nothing back. Fair enough, ill use the forums in future as SOMEONE responds…but i have to say given the hundreds off dollars ive spent on RW and hours invested in it, the stacks support generally from developers from either their sites or self hosted help is poor in my experience.

not trying to upset anyone, but certainly done accepting that anymore. there are other options just as competitive and powerful now.

Looking for those logs now, perhaps we’ll find something, as i say, worked just fine a week or two ago, suddenly after a number of stacks updates - and possibly changes at DH (not ruling out) its blank pages all day.

edit- nothing in the site logs, at all - as in empty - contacting DH

I am not sure what email address you are sending email into but I don’t have any records of any emails recently. The last email I have from you was in February.

My official support email is at the bottom of my support page. Click on the button…

The quickest way to get help is by posting on my WS community. I always prioritize posts there. Some days I do not get around to the email inbox.

I use Dreamhost for my testing server. The recently (last week) moved me to a new server. Maybe this could have been the cause of your issues.

I’ve had to contact their support, the log folder for the site is completely empty.

OK! Fun times…

DH replied…

" Upon checking the logs, it looks like the issue is caused by the MySQL
credentials in this path:

the moment i delete this file, the page appears, my credentials are precisely correct, i even went to the currently functioning visible site RW project.

Absolutely no idea what the hell is going on here…i republish, blank again php file gets republished :-(

So you looked in that file and verified the credentials are correct in the published file on the server?

I also don’t have any record of emails sent to us for this issue. Please be sure to send messages to support [at] nimblehost (dot) com.

Troubleshooting PHP likely means providing temporary credentials to the server to investigate further. Please feel free to send me an email to the address above if this is feasible.

1 Like

Yes, DH have now told me two different things to edit the Armadillo php file…in particular changing the localhost name, which did not work…nor in the stack itself after publishing.

The latest is :

Hi Im Back, ill send from a couple of different emails, we’re about to change email hosts coz Dreamhost mail is crummy as hell, ill send from an email starting with groovequantize


Jonathan can you please make some effort to help me with your plugin and stacks?