Can cookies break my website? HELP please

As you can tell from the title, I’m not a pro. But thanks to RW and stacks, you can get quite far if you’re a little technical. Here is the thing:
I’ve got a website that I’m updating because my book is being published tomorrow.
I use RW8, Foundation6 and Stacks4.3

On 25th August, I loaded the latest update for the Foundation6 theme
On 27th August am, I worked on the ‘Buy the book’ buttons with a 2-column pop up, and published the changes. All good.
On 27th August pm, I started to play with CookieManager and Gateway to be GDPR compliant. Then luckily I realised that one page of the website (I wasn’t working on it at all) didn’t load properly on RW. One tab doesn’t load and the newsletter subscription stack doesn’t work as it should.

Now for the weird thing, a backup of the project of the same website which I haven’t touched since June shows the same problems! A second backup (May) opens directly on the problematic page and it all looks fine. It’s only when I switch to the editor, and then back to the viewer that the problem appears. 😵‍💫
So I’m guessing it’s RW rendering. But actually when I publish that older backup on an old location, the problematic page gets published…
I thought it could have something to do with Gateway and CookieManager, so I deleted them, deleted cookies of each page in RW (but they come back every time you recall the page), even deleted cookies on Safari… Needless to say the problem remains. I can’t understand what’s going on.

Here is a link to the page that works:

Here is a link to the page that doesn’t work:

(The Symbolism tab doesn’t open and the newsletter part doesn’t stick.)

I have to admit that there are two issues that have been there for a while but never seemed to create any problems (up until now?):

  1. My Foundation 6 theme is on v6.14.1 and the Foundation stacks is on v.6.11.11 and it won’t update to v6.14
  2. There is a Javascript error message but I can’t read it because of the first Foundation version warning which is in front of it.

What is weird though is that today, between morning and afternoon, the only work I had down was with cookies. And now it’s broken. Any ideas from you wizards would be most appreciated indeed, if you will!

Many thanks,

Hi Raphael,

Maybe update your Stacks plugin to v.5 and check your PHP and set it to 8/8.1.

Basically update everything. Reach out to @joeworkman about the Foundation issue, he can help you.

good luck on your release!

I am no expert in troubleshooting, but the site that doesn’t work properly, shows the following errors when loading:


(The missing png - last 404 error happens on both websites).

Maybe some other exoperts can shed light on JS error.

1 Like

Thanks Basswow,
I’ve contacted Joe. Regarding the updates, I’m a little scared that some of the stacks would stop working if I move to Stacks v.5. I’m in the middle of publishing teasers once a week! As far as I know, I don’t need PHP but I’m no expert.

Thanks GKs. I hope so, I’ve no idea what to do with that…

I would dare to say that your stacks could work better with the v. 5 Stacks.

PHP is essential and it’s recommended to keep it up to date. Would have to be changed Server side.
Here some info:

Latest version is 8.1

I assume that you did not read the release notes for Foundation 6.14. Have a look at this FAQ.

1 Like

The bandaid is super easy (above FAQ). I looked into your page and it seems to be Scribe. I could be wrong. I sent a message to @tav just to make sure.

1 Like

Its fixed now


Hi Joe,
Thanks for the link. I can’t see jQuery Legacy Support but jQuery 3 Require. Is that the same thing? I’ve loaded it but it didn’t change anything. I’ve also updated Scribe and Pin.

Also I can’t see anywhere online how to get the Addons/Stacks/Weaver’s Space/Foundation6 to be on v6.14. I’m still on v6.11.11. I can’t seem to remove that Foundation Version Warning banner.

Ideally, I’d need to publish a new teaser for my website on Friday but I don’t think I’ll sort it out by then. Is there an archive where I can download v6.13.9 and downgrade to see me though Friday?

Thanks a million

Thanks! I’ve updated Scribe and Pin but the banner is still there. Must be some other stacks lurking somewhere…
My site is now a little less broken but sometimes the content in the Aside section of the Sidebar isn’t showing. Not sure if it’s something to do with the stack.

Also do the BWD stacks work with Stacks 5?

Foundation 6.14 requires Stacks 5. This is why you are stuck at v6.11.

And yes, all BWD stacks work in Stacks 5.

Yes - this has got nothing to do with Stacks 5. Stacks should load the maximum version of jQuery tolerated by any of the stacks on the page. F6 now forces jQuery 3, not Stacks 5.

It’s easy to find any incompatible stacks just by making a test page with just that stack on it and previewing the page. Some of these older stacks have not been updated for over 7 years but I will do so as soon as the problem is highlighted to me. (Note that there are many stacks released by others this year that still have jQuery 2 only code in them!)

I am confident that Pin and Scribe (Drop cap child) are now jQuery3 compliant but if you find any others then I’ll get them sorted out. Just to re-iterate, I updated all my stacks over 2 years ago but obviously missed some of the lesser used child stacks that they share. This was my fault, I was moving house at the time and I didn’t go through all of the older things sufficiently.


Thanks Joe, both Javascript and Foundation version banners are gone. Yeay!
But the website is still broken. When I first open the project it all looks fine, and then when I switch to another page and come back, the first page looks bad. How is that even possible?
I’ll reply to tav below with pictures.

After updates both banners are gone but the website still doesn’t work.
The very weird thing is that when opening a project the page looks as it should:

But when I view another page and come back everything changes!

Rapidweaver never behaved like that before!
All the other pages apart from the Contact page behave the same way and are clipped at the top with Aside sections missing and backgrounds not being rendered properly.
Happy to buy RW9 if it sorts the problem out but will it?

Is this a cache issue? Try previewing the page in a Safari Private window to exclude this possibility.

Just done and it’s the same behaviour! First page looks great. Hit refresh and it goes wrong as per the pictures. Can’t be from some cookies installed when I tried CookieManager or Gateway, can it?
Many thanks

I’ve just looked at your live site and the page takes a long time to load but I do notice the appearance of the menu after a delay - this pushes the page down a little. It would seem that it is not appearing at all on your machine as your screenshot has no hamburger visible. Why it loads the first time but not on refresh on your machine is bizarre but it works for me all the time.

Hi tav,
Have you looked at this website? It’s the upload I made after RW went crazy.
(The is functioning as it should.)

Home Page | The Geometry of the Last Supper (try refreshing)
Teasers Page | The Geometry of the Last Supper (The newsletter on the right has no background and doesn’t stick)

Hamburger is absent most of the times.
It’s the same website as the currently published one but it doesn’t work properly… I’m lost. Puzzled.

Many thanks!